ドキュメンテーション センター

  • 評価版
  • 製品アップデート

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

wvtool

ウィンドウの可視化ツールを起動

構文

wvtool(WindowVector)
wvtool(WinObj)
wvtool(WindowVector1,WinObj1,...,WinObjN,WindowVectorN)
H = wvtool(...)

説明

wvtool(WindowVector) では、WVTool (Window Visualization Tool) が開き、WindowVector で指定したウィンドウ ベクトルの時間領域と周波数領域のプロットが表示されます。WindowVector は実数値の要素をもつ行ベクトルまたは列ベクトルでなくてはなりません。既定の設定では、周波数領域プロットはウィンドウ ベクトル (dB 単位) のフーリエ変換の振幅 2 乗です。Signal Processing Toolbox™ ソフトウェアを使用して、多くの共通のウィンドウ関数に対するウィンドウ ベクトルを生成することができます。サポートされているウィンドウ関数の一覧については、「window」を参照してください。

wvtool(WinObj) では、sigwin オブジェクト WinObj の時間と周波数の領域プロットをもつ WVTool が開きます。サポートされているウィンドウ オブジェクトの一覧については、「sigwin」を参照してください。

wvtool(WindowVector1,WinObj1,...,WinObjN,WindowVectorN) では、WindowVector1,WinObj1,...,WinObjN, WindowVectorN で指定されるウィンドウ ベクトルまたはウィンドウ オブジェクトの時間と周波数の領域プロットをもつ WVTool が開きます。

H = wvtool(...) では、Figure ハンドル H が返されます。

    メモ:   ウィンドウの設計と解析用に、関連ツール wintool も用意されています。

    メモ:   FDATool から WVTool を起動した場合、FDATool からの新しいウィンドウの追加をコントロールする [追加/置換] アイコンがツール バーに表示されます。

WVTool メニュー

wvtool には、通常のメニュー項目のほかに、wvtool 固有の以下のメニュー コマンドが含まれています。

[ファイル] メニュー :

  • エクスポート — 表示されているプロットをグラフィック ファイルにエクスポートします。

[編集] メニュー :

  • Figure のコピー — 表示されているプロットをクリップボードにコピーします (Windows プラットフォームのみ)。

  • コピー オプション — [設定] ダイアログ ボックスを表示します (Windows プラットフォームのみ)。

  • Figure プロパティAxes プロパティ、および 現在のオブジェクト プロパティ — プロパティ エディターを表示します。

[表示] メニュー :

  • 時間領域 — 時間領域のプロットを表示する場合は、ここをチェックします。

  • 周波数領域 — 周波数領域のプロットを表示する場合は、ここをチェックします。

  • 凡例 — ウィンドウ名の凡例の表示/非表示を切り替えます。ツール バーの [凡例] ボタンから、このオプションを使用することもできます。

  • 解析パラメーター — データ数、範囲、x 軸と y 軸の単位、サンプリング周波数など、応答プロットのパラメーターをコントロールします。

    また、ウィンドウの表示パネルにプロットされている x 軸ラベルを右クリックして、解析パラメーターにアクセスすることもできます。

  • [挿入] メニュー:

[挿入] メニューを使用すると、ラベル、タイトル、矢印、線、テキスト、軸をプロットに追加できます。

[ツール] メニュー:

  • プロットの編集 — プロット編集モードを有効にします。

  • ズームインx 軸および y 軸をともに拡大します。

  • X ズームx 軸のみを拡大します。x 方向にマウスをドラッグして、拡大領域を選択します。

  • Y ズーム — y 軸のみを拡大します。y 方向にマウスをドラッグして、拡大領域を選択します。

  • フル ビュー — 全体表示に戻ります。

ハミング、ハン、ガウス ウィンドウを比較します。

wvtool(hamming(64),hann(64),gausswin(64))
 

カイザー ウィンドウ オブジェクトを別のベータ値と比較します。

H = sigwin.kaiser(128,1.5);
% Kaiser window with beta=4.5
H1 = sigwin.kaiser(128,4.5);
wvtool(H,H1)

参考

| | |

この情報は役に立ちましたか?