ドキュメンテーション センター

  • 評価版
  • 製品アップデート

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

colormapeditor

カラーマップ エディターを開く

構文

colormapeditor

説明

colormapeditor は、カラーマップ エディター内で四角形のセルから構成されるストリップとして、現在の Figure のカラーマップを表示します。ノード ポインターとは、カラーマップ ストリップの下に表示される色付きのセルで、カラーマップ内で R、G、B 値の構成比が変化する点を示します。[[色空間の内挿] セレクターを HSV に設定すれば、HSV 色空間で操作することもできます。

カラーマップ エディターは、[編集] メニューから[カラーマップ] を選択しても起動できます。

ノード ポインターの操作

ノード ポインターを選択および移動することで、カラーマップにおける色の範囲を変化させることができます。ノード ポインターの色は移動しても変わりませんが、カラーマップは、ノード間で RGB 値を線形内挿することにより変化します。

ノード ポインターをダブルクリックして、ノード位置における色を変更できます。カラー ピッカーが表示されるので、そこから新しい色を選択することができます。ノード位置における新しい色を選択すると、ノード間の色が再内挿されます。

GUI の [ツール] メニューの [標準のカラーマップ] を使用すると、異なるカラーマップを選択できます。プロット ツールのプロパティ エディターには標準のカラーマップから選択できるドロップダウン メニューがありますが、ここでカラーマップを変更することはできません。

操作

実行方法

組み込みカラーマップを選択

[ツール][標準のカラーマップ]

ノードを追加

カラーマップ ストリップ内の対応するセルの下をクリックします。

ノードを選択

ノードを左クリックします。

複数のノードを選択

隣接する場合: 最初のノードを左クリックし、最後のノードを Shift キーを押しながらクリックします。

離れている場合: 最初のノードを左クリックし、以降のノードを Ctrl キーを押しながらクリックします。

ノードを移動

マウスで選択してドラッグするか、選択して左矢印キーと右矢印キーを使用します。

複数のノードを移動

複数のノードを選択し、左矢印キーと右矢印キーを使ってグループとしてノードをグループで移動します。選択したノードの 1 つが選択されていないノードか末端のノードに達した時点で移動は終了します。

ノードを削除

ノードを選択し、Delete キーを押すか、[編集] メニューから [削除] を選択するか、あるいは Ctrl + x キーを押します。

複数のノードを削除

ノードを選択し、Delete キーを押すか、[編集] メニューから [削除] を選択するか、あるいは Ctrl + x キーを押します。

ノードに対してカラー ピッカーを表示

ノード ポインターをダブルクリックします。

現在の色情報

カラー セルあるいはノード ポインターにマウス ポインターを合わせると、カラーマップ エディターは、そのカラーマップ要素に関して以下の情報を表示します。

  • カラーマップにおける要素のインデックス

  • そのノードの色にマッピングされているグラフィックス オブジェクト カラー データからの値 (Figure 内にある image、patch、あるいは surface オブジェクトの CData プロパティから得られたデータ)

  • 色の RGB および HSV 色値

色空間の内挿

色空間は、ノード間のセルの色を計算するために使用される値を決定します。たとえば、RGB カラー空間の場合、ノード間の色は、あるノードと以下のノードがもつ赤、緑、青の強度値を線形内挿することによって計算されます。色空間を HSV に切り替えると、カラーマップ エディターは色定義における色相、彩度、明度の成分を使って、ノード間の色を再計算することになります。

ある色空間から別の色空間へ切り替える場合、カラーマップ エディターは、ノード ポインターの数、色、位置を保持します。これによってカラーマップの変更が可能になります。

HSV での内挿-  色相は概念上、色の円を回る形でマッピングされるため、色相値の間の内挿は理解しにくい場合があります。このあいまいさを最小限に抑えるため、内挿では円を回る最短距離を使用します。たとえば、色相 2 (わずかにオレンジがかった赤) と色相 356 (わずかにマゼンタがかった赤) の 2 つのノード間における内挿は、色相 3、4、5、... 353、354、355 (オレンジがかった赤-黄-緑-シアン-青-マゼンタ/赤) という変化にはなりません。円を回る最短距離を採用するため、357、358、1、2 (オレンジ/赤-赤-マゼンタ/赤) という変化になります。

カラー データの最小と最大

[最小カラー データ] および [最大カラー データ] というテキスト フィールドを使用すると、Axes の CLim プロパティの値を指定できます。これらの値は、オブジェクト カラー データ (image、patche、および surface の CData プロパティ) からカラーマップへのマッピングを変更します。このプロパティの詳細と使用方法は、「Axes の色の範囲 — CLim プロパティ」を参照してください。

この例では、データ値の範囲が色の指定範囲で表示されるように、既定の MATLAB® カラーマップを変更します。使用するグラフは、ジェット ノズルを通して排出される流量の断面を描くスライス平面です。この種のグラフの詳細は、slice のリファレンス ページを参照してください。

例の目的

目的は以下のとおりです。

  • 左から右へ流れる領域 (正のデータ) を、黄色からオレンジを経て暗い赤までの色にマッピングします。黄色は最も低速、暗い赤は最も高速で移動する流体を表します。

  • 速度がゼロに近い領域は、緑色にします。

  • 流体が実際には右から左へ移動する領域 (負のデータ) は、青の色調で表示します (青が暗いほど高速)。

以下の図は、スライス平面を希望どおりに着色した状態です。カラー バーが、データから色へのマッピングを示しています。

例の実行

    メモ:   このドキュメンテーションを MATLAB のヘルプ ブラウザーで閲覧している場合には、このファイルこのファイルを MATLAB エディターから実行することにより ([デバッグ] メニューから [実行] を選択)、この例で使用されているグラフを表示することができます。

最初に、次の図で示すように、既定のカラーマップ (jet) でスライス平面を着色します。この例では色をより幅広い帯状に表示するため、48 要素のカラーマップを使っていることに注意してください (既定の設定は64要素)。

  1. colormapeditor コマンドを使用してカラーマップ エディターを起動します。カラーマップ エディターは、以下の図に示すように、現在の Figure のカラーマップを表示します。

  2. 左から右への流れの領域 (正の速度) を黄色から暗い赤の範囲で表示したいので、シアンのノード ポインターを削除します。削除するには、マウスの左ボタンでノード ポインターをクリックしてから、Delete キーを押します。カラーマップの表示が次のように変わります。

    [すぐに適用] チェック ボックスがオンになっているため、カラーマップに対する変更の結果がグラフに反映されます。

  3. ゼロ付近での流速値を強調したいので、負から正への変化が生じるカラー セルを見つける必要があります。カラー ストリップ上でカーソルを移動させると、[現在の色情報] パネルでデータ値を読み取ることができます。

    この例ではセル 10 が最初の正の値であるため、そのセルの下をクリックしてノード ポインターを作成します。作成したノード ポインターをダブルクリックすると、カラー ピッカーが表示されます。このノードのカラーを緑色に設定します。

    カラーマップの変更に対応して引き続きグラフが更新されます。

  4. 現在の状態では、カラーマップの色は、先に作成した緑色のノードから約 20 セル離れた黄色のノードまで内挿されています。実際には、ゼロ付近を中心として緑色にしたいセルは 1 つだけです。緑色を 1 つのセルに制限するため、青と黄色のノード ポインターを緑色のポインターの隣に移動します。

  5. カラーマップをさらに調整する前に、緑色のセルの中心がゼロ付近となるように、緑色のセルを移動する必要があります。カラー バーを使って緑色のセルを配置します。

    緑色のセルの中心がゼロ付近となるように再配置するため、青、緑、黄色のノード ポインターを選択し (青を左クリックし、黄色を Shift キーを押しながらクリック)、左矢印キーを使って全体をグループとして移動します。Figure ウィンドウのカラー バーを注意深く観察し、緑色の中心がゼロ付近となるように調整します。

    スライス平面は、負、ゼロ、正のデータに希望する範囲の色が設定される状態となりました。

  6. 赤のノード ポインターを移動して黄色のノードに近づけることにより、スライス平面でオレンジ/赤に着色される領域を広げます。

  7. 極端なデータとなった領域が詳細にわかるようにするため、両端部分の色を暗くします。両端のノードをダブルクリックして、カラー ピッカーを表示します。赤のエンドポイントには RGB 値 [50 0 0]、青のエンドポイントには RGB 値 [0 0 50] を設定します。

    スライス平面は、例の目的に合致する着色状態となりました。

変更したカラーマップの保存

変更したカラーマップは、関数 colormap あるいは Figure の Colormap プロパティを使用して保存することができます。

変更内容を適用したら、現在の Figure のカラーマップを変数に保存します。

mycmap = get(fig,'Colormap'); % fig is figure handle or use gcf

このカラーマップを別の Figure で使用するには、Figure の Colormap プロパティを設定します。

set(new_fig,'Colormap',mycmap)

変更したカラーマップを MAT ファイルに保存するには、save コマンドを使用して mycmap ワークスペース変数を保存します。

save('MyColormaps','mycmap')

保存したカラーマップを別の MATLAB セッションで使用するには、この変数をワークスペースに load し、カラーマップを Figure に割り当てます。

load('MyColormaps','mycmap')
set(fig,'Colormap',mycmap)

参考

| | | | |

この情報は役に立ちましたか?