ドキュメンテーション センター

  • 評価版
  • 製品アップデート

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

ファイルとフォルダーの比較

ファイルとフォルダーの比較

選択した 2 個のファイルまたはフォルダー間の違いを判別して表示するには、比較ツールを使用します。比較プロセスには 3 つの手順があります。

  1. 比較するファイルやフォルダーを選択する

  2. 比較タイプの選択

  3. 比較ツール レポートの参照

比較するファイルやフォルダーを選択する

ファイルやフォルダーの比較は、次のいずれかの方法を使用できます。

  • 現在のフォルダー ブラウザーから次のようにします。

    • ファイルまたはフォルダーを選択し、右クリックして [比較対象を指定] を選択し、比較対象となる項目を選択します。

    • 同じフォルダー内の 2 個のファイルまたはサブフォルダーの場合は、ファイルまたはフォルダーを選択して右クリックし、[選択したファイル/フォルダーを比較] を選択します。

  • ファイルがエディターで開かれている場合、[エディター] タブの [ファイル] セクションから次のようにします。

  • MATLAB® デスクトップの [ホーム] タブの [ファイル] セクションで、[比較] をクリックします。比較するファイルまたはフォルダーを選択します。

  • コマンド ラインで、関数 visdiff を使用します。

比較タイプの選択

現在のフォルダー ブラウザーまたは関数 visdiff のいずれかを使用して、比較するファイルまたはフォルダーを 2 つ指定する場合、比較ツールは自動的に既定の比較タイプを実行します。

複数の比較タイプを選択できる場合、実行する比較タイプを変更できます。たとえば、テキスト比較、バイナリ比較、ファイル リスト比較、XML 比較などです。比較の種類を変更するには、比較ツールを使用して新しい比較を作成します。[比較するファイルまたはフォルダーの選択] ダイアログ ボックスで、比較タイプを変更できます。

たとえば、現在のフォルダー ブラウザーから、比較する MAT ファイルを 2 つ選択すると、変数についての情報を表示する既定の比較タイプが得られます。比較タイプをバイナリに変更するには、比較ツールを使用して新しい比較を作成します。「比較するファイルまたはフォルダーを比較ツールから選択」を参照してください。

比較ツール レポートの参照

比較ツール レポート機能は、比較タイプに応じて異なります。このツールは以下の目的で使用できます。

  • 2 個のテキスト ファイルの行を比較 (他のアプリケーションでは、これをファイルの “ファイルの差分” 処理と呼んでいます)。「テキスト ファイルの比較」を参照してください。

  • 2 つの MAT ファイルの変数の比較と結合。「MAT ファイルの比較」を参照してください。

  • 2 つのバイナリ ファイルの内容が一致するかどうかの確認。「バイナリ ファイルの比較」を参照してください。

  • フォルダー、ZIP ファイル、または Simulink® マニフェストの任意の組み合わせの比較

    • 各リストでどのファイル名とフォルダー名が固有であるか

    • 各リストで同じ名前のファイルやフォルダーが同じ内容かどうか

    フォルダーと Zip ファイルの比較 を参照してください。

  • XML ファイルの比較:

    • 比較する XML ファイルを選択し、かつ MATLAB Report Generator™ ソフトウェアがインストールされている場合は、比較ツールによって階層照合アルゴリズムが実行されます。次に、2 個の XML ファイルの相違部分を階層ビューで示したレポートが表示されます。

    • Simulink Report Generator ソフトウェアがインストールされている場合は、Simulink モデルのペアを選択して、そこから生成される XML ファイルを比較することができます。

フォルダーと Zip ファイルの比較

フォルダーの比較レポート

比較する項目を選択するには、「比較するファイルやフォルダーを選択する」を参照してください。フォルダー、zip ファイル、および Simulink マニフェストの任意の組み合わせに対して、ファイル リスト比較を実行できます。

比較ツールを使用して 2 つのフォルダー (ディレクトリとも呼ばれる) または任意のファイル リスト (フォルダーと zip ファイルなど) を比較する場合、ウィンドウが開いて内容が並べて表示されます。このツールでは以下が行えます。

  • 比較リスト間で共通なファイルを判別する

  • 比較リスト間で同じ名前のファイルがある場合、その内容も同じであるかどうかを判別する

  • 両方の比較リストに共通するが内容が異なる 2 個のファイルまたはフォルダーを開いて新規に比較する

  • エディターで表示するためにファイルを開く

  • 特定のファイルまたはフォルダーを無視するフィルターを指定する

リスト比較では、リストを展開してサブフォルダー内のすべてのファイルを 1 つのレポートで表示する場合、比較する項目を選択するときに [サブフォルダーを含む] チェック ボックスを選択します。サブフォルダーを含めない場合は、レポートの [比較] リンクをクリックして、内容が変更された 2 つのフォルダーで新規に比較できます。

重要でない差異を除外するフィルターを定義するには、[表示] タブで [フィルター] ボタン をクリックし、[フィルターの追加/削除] を選択します。

ファイルとフォルダーのフィルターのダイアログ ボックスが開きます。バックアップ ファイルや、改訂管理システムが作成したファイルなど、特定のファイルとフォルダーを無視するフィルターを指定します。フィルターを使用すると、特に多数のサブフォルダーを比較する際に、差異の確認する時間を節約することができます。既存のフィルターを編集するにはダブルクリックします。

たとえば、CVS という名前のフォルダーの中のすべてのファイルとフォルダーを無視するには、ファイルとフォルダーのフィルターのダイアログ ボックスを開き次のように入力します。

CVS/

CVS という名前のフォルダーのすべてのファイルを無視し、サブフォルダーは無視しないようにするには、次のように入力します。

CVS/*

相違点の強調表示

比較ツールはリストの内容を並べて表示し、一致しないファイルとサブフォルダーを強調表示します。次の表に、どのように強調表示されるかを変更タイプごとに説明します。ステータス メッセージ ([同一][内容変更]) は [変更概要] 列に表示されます。

変更概要フォルダーの強調表示ファイルの協調表示メモ:
[内容変更]濃いピンクピンクファイルまたはフォルダーの内容が異なります。調べる [比較] リンクをクリックします。
[追加済み]濃い緑ファイルまたはフォルダーは右側のリストにしかありません。
[削除済み]濃い紫ファイルまたはフォルダーは左側のリストにしかありません。
[同一]なしなし 

次の図は、比較ツールを使用して、2 つのフォルダーを比較した例を示します。結果は [種類] 別に並べ替えます。

レポートを使用した次の手順

レポートを調べるには、以下のツールを使用できます。

  • 結果は列見出しをクリックして、名前、種類、サイズ、最終更新タイムスタンプなどを基準に並べ替えることができます。たとえば、上の図のように、フォルダーやファイルの種類で並べ替えるには、列見出し [種類] をクリックします。

  • 内容が変更された 2 つのファイルまたはフォルダーを新規に比較する場合、ピンクで強調されたファイルまたはフォルダーの名前の横の [比較] リンクをクリックします。

  • ファイルをエディターで開くには、ファイル名の横の [開く] リンクをクリックします。

    ファイルが両方のフォルダーにある場合は、リンクをクリックして [左] または [右] のファイルを開きます。

  • サブフォルダーが大容量で多数のファイルが含まれている場合は、バックグラウンドで分析が続行します。次の図のように、まだ比較していない項目の数がレポートの一番上に表示されます。リンクをクリックして [現在の項目をスキップ] するか、[すべてキャンセル] して分析を中止します。

  • 比較ツールのその他の機能の詳細は、「比較ツールの機能の使い方」を参照してください。

テキスト ファイルの比較

比較するテキスト ファイルの選択

比較するファイルを選択するには、「比較するファイルやフォルダーを選択する」を参照してください。

テキスト比較の例を表示するには、次のように入力します。

visdiff(fullfile(matlabroot,'help','techdoc','matlab_env',...
'examples','lengthofline.m'), fullfile(matlabroot,'help',...
'techdoc','matlab_env','examples','lengthofline2.m'))

相違点の強調表示

比較ツールを使用して 2 個のテキスト ファイルを比較する場合、ウィンドウが開いて、これらのファイルが並んで表示されます。記号は、それらを一致させるためにファイルを調整する方法を示します。この機能は、テキスト ファイルの最新バージョンを自動保存バージョンと比較するときに便利です。

比較ツールのレポートは、次のようにファイルを並べて表示し、一致しない行を強調表示します。

  • 濃いピンク色の強調表示は、行内で変更された文字を示します。

  • ピンク色の強調表示と 2 つのファイルの間にある x は、2 つのファイル間で行の内容が異なることを示します。

  • 緑色の強調表示と 2 つのファイルの間にある右 (>) または左 (< ) の山かっこは、一方だけにある行を示します。

比較ツールは行を比較して、追加、削除、または変更されているローカル テキストを検出しようとします。1 行ごとの単純な比較は行いません。たとえば、上図は lengthofline.mlengthofline2.m にはないコード行があることを示し、緑色で強調表示 (23 行目) しています。また、比較ツールは追加の行を考慮に入れ、end ステートメントが同じ行番号にない場合でも、各ファイルの end ステートメントの行が一致すると判断します。

比較するファイルが極めて長い場合は、ファイルの比較を実行しようとするとメモリ不足になる可能性があります。この場合は、次のメッセージ

「最大のファイル長を超えました。行単位の比較を既定の設定にします。」

が表示されます。1 行ごとの比較では、この処理中に一方のファイルの最終行がもう一方のファイルの最終行と一致しないことが検出されるため、end ステートメントを含んだ行が強調表示されます。

相違点の移動

テキスト ファイルが長い場合もあるため、比較ツールではツールストリップのボタンを使用して結果を移動します。

比較結果を移動するには、次の手順に従います。

  • 違いが見つかった次の行セットに移動するには、右矢印ボタンをクリックします。

    次の差分行が存在しない場合、右矢印をクリックするとファイルの末尾に移動します。

  • 違いが見つかった前の行セットに移動するには、左矢印ボタンをクリックします。

    前の差分行が存在しない場合、左矢印をクリックするとファイルの先頭に移動します。

差分の概要の表示

2 つのテキスト ファイル間の差分の概要を表示するには、比較ツールの下までスクロールして、以下のような情報を含むリストを表示します。

  • 一致した行数: 51

  • Number of unmatched lines in left-hand file: 13

  • Number of unmatched lines in right-hand file: 16

テキスト比較で空白の差異を無視する

空白の差異を非表示にして、関数の変更とインデントの変更を区別できます。

[表示] タブで [フィルター] ボタンをクリックし、[空白文字を無視] のチェック ボックスをオンまたはオフにして、空白文字のみによる差異を表示するかどうかを切り替えます。

差分のみを表示する

差分のみを表示するかファイル全体を表示するか指定できます。サイズの大きい比較レポートで、変更されていない行を隠す場合に便利です。差分のみを表示しセクションは隠している場合は、レポートは次のようなメッセージを表示します。 10 unmodified lines hidden.

[表示] タブで [フィルター] ボタンをクリックし、[差分のみを表示] のチェック ボックスをオンまたはオフにして、レポート内の差異を含まないセクションを表示するかどうかを切り替えます。

テキスト比較の表示幅の変更

比較表示でのテキスト ファイルの行の長さを調整することができます。[表示] タブの [表示] セクションで [列幅] 編集ボックスの数字を編集します。必要に応じて、ウィンドウ サイズを変更します。

比較ツールのその他の機能の詳細は、「比較ツールの機能の使い方」を参照してください。

HTML レポートの保存

[比較] タブの [比較] セクションで [名前を付けて保存][HTML として保存] をクリックすると、比較レポートのコピーを HTML ファイルで保存できます。レポートの強調表示を制御するスタイル シートと JavaScript® ファイルを含む、対応するフォルダーが作成されます。強調表示を保存するには、HTML ファイルを格納したフォルダーを保持します。

    メモ:   MATLAB でファイルを開くレポート リンクは、MATLAB Web ブラウザーでのみ機能します。

自動保存バージョンまたはディスク上のバージョンのファイルとの比較

エディターから、開いているテキスト ファイルを別のテキスト ファイルと比較したり、エディター内のファイルの最新バージョンを自動保存バージョンまたは保存済みバージョンと比較したりできます。たとえば、以下の手順に従います。

  1. 比較するファイルの 1 つをエディターで開きます。

    提供されている例のファイル lengthofline.m を開くには、コマンド ウィンドウで以下のコマンドを実行します。

    open(fullfile(matlabroot,'help','techdoc','matlab_env',...
    	'examples','lengthofline.m'))
    
  2. [エディター] タブの [ファイル] セクションで、[比較] をクリックします。ファイルが変更されている場合、エディターはファイルを保存してから比較します。[比較] の下で [保存および比較] を選択することもできます。

    比較対象のファイルを表示し、選択した後で [開く] をクリックします。たとえば、lengthofline.m が見つかったフォルダーから例ファイル lengthofline2.m を選択します。

    その他のオプションは以下のとおりです。

    • 開いているファイルをエディターの自動コピー (filename.asv) と比較するには、[比較] の下で [自動保存機能による保存および比較] を選択します。ファイルが変更されている場合、エディターはファイルを保存してから比較します。詳細は、「ファイルの自動保存」を参照してください。

    • 変更されていても未保存の開いているファイルを、保存済みバージョンと比較するには、[比較] の下で [ディスク上のバージョンと比較] を選択します。

MAT ファイルの比較

比較ツールを使用して 2 つの MAT ファイルを比較できます。このツールでは、2 つのファイルの変数が並べて表示され、以下の操作を行うことができます。

  • すべての変数の名前、サイズ、クラス、および変更概要ごとに表示し、並べ替える。

  • 変数間の差異の詳細を表示して、構造体のどのフィールドに差異があるか確認し、配列の各要素の差異を表示する。

  • 変更された変数を 1 つのファイルから別のファイルにコピーすることにより、ファイル間の変更を結合します(注意:元に戻せません)。

  • 各ファイルに共通する変数と固有な変数の表示

  • 変数エディターに変数の内容を読み込むには、その変数の名前をクリックします。

  • [読み込み] リンクをクリックして、MAT ファイルをワークスペースに読み込む。

  • レポートのコピーを HTML ファイルとして保存する。ツールストリップの [名前を付けて保存][HTML として保存] をクリックします。

比較ツールで、以下のように変数の変更内容が強調表示されます。

変更概要強調表示メモ:
[変更済み]ピンク変数の値が 2 つのファイルで異なります。
比較リンクをクリックして確認してください。新規の変数比較レポートが開き、配列の各要素の差異または構造体のフィールドの差異を表示します。ピンク色の行またはセルをダブルクリックして差異の詳細な層を調べます。
[追加済み]右側のファイルにのみ変数があります。
[削除済み]左側のファイルにのみ変数があります。
[同一]なし両方のファイルで変数が同一です。
[変更済みのクラス]ピンク ([クラス] 列のみ)変数データ クラスが変更されました。[差異の表示] ボタンをクリックして調べます。

結合列の [マージ] ボタン をクリックして、変更された変数を 1 つのファイルから別のファイルにコピーします。

次の図は、2 個のファイル data1.matdata2.mat を比較した結果を示します。

変数の値が 2 つのファイルで異なる場合は、比較リンクをクリックして確認することができます。新規の変数比較レポートが開き、配列の各要素の差異または構造体のフィールドの差異を表示します。

次の例に示すように、ピンク色の行またはセルをダブルクリックして差異の詳細な層を調べます。

MAT ファイル比較の例を表示するには、次のように入力します。

visdiff(fullfile(matlabroot,'toolbox','matlab','demos','gatlin.mat'), ...
fullfile(matlabroot,'toolbox','matlab','demos','gatlin2.mat'))

バイナリ ファイルの比較

比較ツールを使用して、DLL ファイルや MEX ファイルなど、2 つのバイナリ ファイルを比較できます。また、比較タイプを選択した任意のファイル ペアに対して [バイナリ比較] タイプを選択できます。

  • ファイルが同一である場合、ファイルは同一です

  • ファイルが異なる場合は、次のメッセージが表示されます。ファイルは異なります

ファイルが異なる場合、[詳細を表示] リンクをクリックしてバイナリ ファイルと最初の差異のバイト オフセットを表示できます。

バイナリ比較の例を表示するには、2 つのサンプル テキスト ファイルを比較して、比較タイプをバイナリと指定します。

visdiff(fullfile(matlabroot,'help','techdoc','matlab_env',...
'examples','lengthofline.m'), fullfile(matlabroot,'help',...
'techdoc','matlab_env','examples','lengthofline2.m'), 'binary')

比較ツールの機能の使い方

比較ツールを使って、以下を行うことができます。

比較するファイルまたはフォルダーを比較ツールから選択

比較ツールから 2 個のファイルまたはフォルダーを比較するには、次の手順に従います。

  1. MATLAB デスクトップの [ホーム] タブの [ファイル] セクションで、[比較] をクリックします。比較するファイルまたはフォルダーを選択します。

    比較ツールが既に開いている場合、[新規比較] ボタン をクリックしてファイルまたはフォルダーを比較します。

    [比較するファイルまたはフォルダーの選択] ダイアログ ボックスが表示されます。

  2. ダイアログ ボックスで、比較する 2 つのファイルまたはフォルダーを選択します。ドロップダウン リストを使って最近比較した項目を選択するか、[参照] ボタン を使用して、比較する項目を参照して選択します。

    または、Windows® エクスプローラーからファイルまたはフォルダーをドラッグして、ファイルとフォルダーの左右のフィールドにドロップすることもできます。

  3. オプションで、使用する比較タイプを選択します。既定の [比較タイプ] の値を使用するか、または複数の比較タイプを使用できる場合は、リストから別のタイプを選択します。たとえば、テキスト ファイルの場合は、テキストまたはバイナリ比較タイプを選択できます。

  4. [比較] をクリックします。

レポートの左側と右側の入れ替え

ファイルまたはフォルダーを左側から右側へ、または右側から左側へ移動するには、[比較] タブの [比較] セクションで [左右交換] ボタン をクリックします。

更新ファイル表示のためのレポートの更新

エディターでファイルを変更して保存した後で、比較ツールの結果を更新するには、[比較] タブの [比較] セクションで [更新] ボタン をクリックします。

テキストの検索

現在の表示内で語句を検索するには、[比較] タブの [ナビゲート] セクションで [検索] ボタン をクリックします。表示される検索ダイアログ ボックスは、コマンド ウィンドウで使用するものと同じです。詳細は、「コマンド ウィンドウまたは コマンド履歴でのテキスト検索」を参照してください。

新規比較の作成

別のファイルまたはフォルダーの比較を実行するには、[比較] タブの [比較] セクションで [新規] ボタン をクリックします。

[比較するファイルまたはフォルダーの選択] ダイアログ ボックスが表示されます。最初のファイル フィールドと 2 番目のファイル フィールドで、前回の比較ファイルが事前選択されています。ドロップダウン リストを使って最近比較した項目を選択するか、[参照] ボタン を使用して、比較する項目を参照して選択します。

新規比較が、比較ツールの別のタブに開きます。別のウィンドウにする場合は、ツールの外にタブをドラッグします。

前回の比較の表示

現在のセッションで前回の比較結果を表示するには、ウィンドウ下部にあるドキュメント バーでその比較のタブ エントリを選択します。比較ツールを閉じる場合、現在と以前の比較結果は失われます。

ファイルとフォルダーを比較する関数

コマンド ウィンドウから比較ツールを開くには、関数 visdiff を使います。

visdiff(fileorfoldername1, fileorfoldername2)

たとえば以下のように入力します。

visdiff('lengthofline.m', 'lengthofline2.m')
この情報は役に立ちましたか?