ドキュメンテーション センター

  • 評価版
  • 製品アップデート

このページは前リリースの情報です。該当の英語のページはこのリリースで更新されています。このリリースの英語のドキュメンテーションを参照するには、言語設定を United States に変更してください。

プロット編集モードでの作業

プロット編集モードの Figure ウィンドウ

MATLAB® Figure ウィンドウは、グラフの外観をカスタマイズすることができるポイント/クリック スタイルの編集モードをサポートしています。ここでは、プロット編集モードの起動と基本的な編集の操作方法を説明します。オブジェクトの選択、切り取り、コピー、貼り付け、移動、サイズ変更や、他のプロット プロパティの修正などを説明します。以下の図は、プロット編集モードのいくつかの機能を説明しています。

プロット編集モードの起動

Figure 内でオブジェクトをクリックして選択するには、プロット編集モードをアクティブにする必要があります。プロット編集モードをアクティブにするには、いくつかの方法があります。

  • Figure ウィンドウの [ツール] メニューから [プロットの編集] オプションを選択します。

  • Figure ウィンドウ ツール バーの選択ボタンをクリックします。

  • [編集] または [挿入] メニューからオプションを選択します。たとえば、[編集] メニューの [Axes プロパティ] オプションを選択すると、MATLAB によってプロット編集モードがアクティブになり、Axes が選択された状態で表示されます。

  • MATLAB コマンド ウィンドウで、コマンド plotedit を実行します。

  • plottools コマンドでプロット ツールを起動します。

Figure ウィンドウがプロット編集モードの場合、[ツール] メニューの [プロットの編集] オプションがオンになり、ツール バーの選択ボタンが押された状態となります。

プロット編集モードの終了

プロット編集モードを終了するには、選択ボタンをクリックするか、[ツール] メニューの [プロットの編集] オプションをクリックします。プロット編集モードがオフの場合、選択ボタンは押されていません。

グラフ内のオブジェクトの選択

グラフ内のオブジェクトを選択するには、

  1. プロット編集モードを起動します。

  2. オブジェクトにカーソルを移動し、クリックします。

    選択ハンドルが選択したオブジェクト上に現れます。

    メモ:   オブジェクトを手動で選択すると、そのオブジェクトの Selected プロパティは on に設定されます。SelectionHighlight プロパティの設定にかかわらず、ハンドルが現れます (SelectionHighlight プロパティが off の場合、ハンドルはプロット編集モードの外側に現れません)。プロット編集モードでは、set を使用して選択されたオブジェクト (set(h,'Selected','on') の場合など) は、選択ハンドルをもっていても、選択されているとは見なされません。そのため、プログラム的に選択されたオブジェクトは、[Delete] を押すなどの操作には応答しません。しかし、それらのオブジェクトは、ドラッグすることはできます。ドラッグすると、それらのオブジェクトが手動で選択されるからです。

複数オブジェクトの選択

同時に、複数のオブジェクトを選択するには、以下を行います。

  1. プロット編集モードを起動します。

  2. オブジェクト上にカーソルを移動し、Shift キーを押しながらクリックして選択します。選択するオブジェクトに、この操作を繰り返します。

選択したすべてのオブジェクトに操作を行うことができます。たとえば、グラフからテキストボックス注釈と矢印注釈を削除するには、オブジェクトを選択して、[編集] メニューから [削除] または [切り取り] を選択します ([切り取り] を選択するとオブジェクトがクリップボードにコピーされますが、 [削除] ではコピーされません)。

オブジェクトの選択を解除

オブジェクトの選択状態を解除するには、オブジェクト上に位置するカーソルを Figure ウィンドウの背景上に移動し、左マウスボタンをクリックします (これは、選択したすべてのオブジェクトの選択を解除し、クリックしたオブジェクトを選択します)。また、選択したオブジェクトを Shift キーを押しながらクリックすると、選択解除の状態になります (他のオブジェクトは選択解除しません)。

プロット オブジェクトの切り取り、コピー、貼り付け

グラフからオブジェクトを切り取ったり、グラフ内のオブジェクトをコピー、貼り付けるには、以下の手順を行います。

  1. プロット編集モードを起動します。

  2. オブジェクトを選択します。

  3. [編集] メニューから [切り取り][コピー]、または [貼り付け] オプションを選択するか、使用しているプラットフォームの標準ショートカット キーを使用します。

また、プロット編集モードを有効にして、オブジェクト上を右クリックし、オブジェクトに関連するコンテキスト メニューから編集コマンドを選択します。

複数のオブジェクトのコピーと貼り付け

Figure から Axes オブジェクトと Plot オブジェクト (lineseries や barseries など) を切り取るかコピーして、その Figure 内または他の場所へ貼り付けた場合、その結果は、選択したオブジェクトと、そのオブジェクトを貼り付けるコンテナーのタイプに応じて異なります。

Axes のコピーと貼り付け-  以下のセマンティクスは、同一のまたは別の Figure へ、Axes のコピー、貼り付けを行うと適用されます。

Axes の選択、コピー、貼り付け

Axes を貼り付けた結果

Figure Fig1 から Axes Ax1 を選択し、Axes をもたない Fig2 に貼り付けます。

新規 Axes Ax2 が Fig2 に作成されます。Ax2 は Ax1 のすべてのプロパティ (Children も含む) を継承します。Ax1 は Fig1 で選択された状態に、Ax2 は Fig2 で選択された状態になります。

Figure Fig1 から Axes Ax1 を選択し、(編集メニューから) コピーして、選択されていない Axis Ax2 をもつ Fig2 へ貼り付けます。

新規 Axes Ax3 が Fig2 に作成されます。Ax1 のすべての子は、Ax3 にコピーされます。Fig2 内のすべての選択されたオブジェクトは選択解除され、貼り付けられた Axes Ax3 が選択されます。Fig 1 内の選択は変更されません。

Figure Fig1 から Axes Ax1 を選択し、コピーして、同一のまたは別の Figure にある Ax2 に貼り付けます。

新規 Axis Ax3 が作成され、Ax1 と同じプロパティ (position を含む) と子をもちます。Ax2 の選択されたオブジェクトは、選択解除され、Axes Ax3 が選択されます。新規 Figure に貼り付けると、Fig1 の選択は変更されません。

Figure Fig1 から Axes Ax1 を選択し、コピーして、Fig1 にある同一のまたは別の Axes に貼り付けます。

新規 Axes Ax2 が Fig1 に追加され、Ax1 からオフセットされます。そして Ax2 は選択された唯一のオブジェクトになります。

    メモ:   Axis を既存の Axes に貼り付けると、貼り付けられた Axes は既存の Axes と同じものになり、貼り付けが適切に行われたことを視覚的に示すため、若干オフセットされて貼り付けられます。

プロット オブジェクトのコピーと貼り付け-  以下のセマンティクスは、Axes からプロット オブジェクト (ラインなど) をコピーし、同一のまたは別の Figure への貼り付けに適用されます。

オブジェクトの選択、コピー、貼り付け

オブジェクトを貼り付けた結果

Axes Ax1 から 1 つまたは複数のラインを選択し、コピーして、同一のまたは別の Figure の選択した Axes Ax2 に貼り付けます。

ラインが Ax2 に追加されます。貼り付けられたラインのみが、コピー先の Figure 内で選択されているオブジェクトとなります。

Fig 1 の Axes Ax1 からラインを選択してコピーし、Figure Fig 2 へ貼り付けます。この Fig2 には、Axes がないかまたは選択された Axes がありません。

新規 Axes Ax2 が Fig2 に作成され、選択されたラインを含みます。Ax2 は既定の Axes プロパティをもちます。

Axes Ax1 からラインを選択してコピーし、選択した Axes Ax2 と Ax3 に貼り付けます。

ラインは、Ax2 と Ax3 の両方に貼り付けられます。貼り付けられたすべてのラインは選択されています。

Axes Ax1 からラインを選択してコピーし、選択された Axes Ax1 に貼り付けます。

追加のコンテンツは重複するため、何も貼り付けられません。

複数の Axes からプロット オブジェクトをコピーし、貼り付ける-  以下のセマンティクスは、1 つまたは複数の Axes からプロット オブジェクト (ラインなど) をコピーし、同一のまたは別の Figure へ貼り付けるのに適用されます。

オブジェクトの選択、コピー、貼り付け

オブジェクトを貼り付けた結果

Axes Ax1 から Line1 を、Axes Ax2 から Line2 を選択してコピーし、Axes Ax3 に貼り付けます。

Axes Ax3 に 2 つのラインが貼り付けられ、このラインは、選択された唯一のオブジェクトになります。

Axes Ax1 と Ax2 からラインを選択してコピーし、Figure Fig 2 へ貼り付けます。この Fig2 には、Axes がないかまたは選択された Axes がありません。

新規 Axes Ax3 が、すべてのラインが貼り付けられた状態で Fig2 に作成されます。Ax3 は既定の Axes プロパティをもちます。

Axes Ax1 と Axes Ax2 から複数のラインを選択してコピーし、Ax1、Ax2 または他の Axes に貼り付けます。

その座標軸に存在していなかったラインのみが、その座標軸に貼り付けられます。貼り付けられたラインのみが、選択されているオブジェクトとなります。

複数の Axes とプロット オブジェクトのコピーと貼り付け-  以下のセマンティクスは、1 つまたは複数の Axes から選択されたプロット オブジェクト (ラインなど) と、複数の Axes を、コピーし、同一のまたは別の Figure へ貼り付けると適用されます。

オブジェクトの選択、コピー、貼り付け

オブジェクトを貼り付けた結果

Axes Ax1から Line1 を選択し、 Axes Ax2 を選択し、Figure Fig 2 へ貼り付けます。この Fig2 には、Axes がないか、または選択された Axes がありません。

Ax2 とそのコンテンツは、新規 Axes Ax3 として貼り付けられます。他の新規 Axes Ax4 は、ラインが貼り付けられる場所に作成されます。

Axes Ax1 から Line1 を選択し、Axes Ax2 を選択し、Axes Ax3 に貼り付けます。

Line1 が座標軸 Ax3 に貼り付けられ、座標軸 Ax2 は新規座標軸 Ax4 として貼り付けられます。

Axes Ax1 を選択し、Ax1 から Line1 を選択し、Ax1 へ貼り付けます。

新規 Axes Ax2 が作成されます。この Axes は Ax1 のすべてのプロパティをもち、唯一の子オブジェクトとして Line1 をもちます。

Axes Ax1 を選択し、Fig 1 の Axes からラインを選択してコピーし、Figure Fig 2 へ貼り付けます。この Fig2 には、Axes がないか、または選択された Axes がありません。

Line1 は、新規 Axes Ax2 に貼り付けられ、Ax1 とその子オブジェクト (Line1 を含む) は、新規 Axes Ax3 として貼り付けられます。

Axes Ax1 を選択し、Ax1 から Line1 を選択し、Axes Ax2 へ貼り付けます。

新規 Axes Ax3 が作成されます。この Axes は Ax1 のすべてのプロパティをもち、唯一の子オブジェクトとして Line1 をもちます。

注釈オブジェクトのコピーと貼り付け

プロット編集モードでは、テキスト ボックス、テキスト矢印、四角形、楕円などの注釈をさまざまな組み合わせでコピーし、貼り付けられます。このようなオブジェクトがオブジェクトの座標軸に固定されている場合 (「グラフ内の一点に固定」を参照) は、オブジェクトのコピーは固定を解除して貼り付けられます。Annotation オブジェクトは Figure の子オブジェクトであり、Annotation オブジェクトを貼り付けても、新規座標軸は作成されません。

オブジェクトの移動とサイズ変更

グラフ内のオブジェクトを移動したり、サイズ変更するには、以下の手順を実行します。

  1. プロット編集モードを起動します。

  2. オブジェクトを選択します。カーソルがオブジェクト上にある場合、カーソルは交差した矢印になり、選択ハンドルがオブジェクト上に現れます。選択外では、元のポインターになります。

オブジェクトを移動するには、新規位置までドラッグします。キーボードの適切な矢印キーを使用して、そのオブジェクトを 1 ピクセルずつ上下左右に微調整することもできます。[ツール] メニューから [レイアウト グリッドにスナップ]を選択すると、キーを押すたびにオブジェクトは隣のグリッド位置へ移動します。

オブジェクトをサイズ変更するには、選択ハンドルをドラッグします。

Shift キーを押しながらクリックして、複数のオブジェクトを選択すると、それらをグループとして移動することができます。矢印キーは、この場合にも使用できます。しかし、選択したいくつかのオブジェクトのうちの 1 つをサイズ変更すると、そのオブジェクトのみサイズが変更されます。

    メモ:   テキストオブジェクトは移動できますが、サイズ変更はできません (注釈テキストボックスは、サイズ変更できます)。Axes オブジェクトはサイズ変更できますが、移動は、そのエッジをドラッグする (あるいは選択ハンドルを1つずつ使用する) という方法でしか行えません 。

オブジェクト プロパティの設定

MATLAB のグラフ内のすべてのオブジェクトは、グラフの外観、動作をコントロールする一連のプロパティをサポートしています。たとえば、ライン オブジェクトは、幅、カラー、ライン スタイルをコントロールするプロパティをサポートしています。

オブジェクトをダブルクリックするとプロパティ エディターが表示されます。Axes または Figure のプロパティを編集するには、他のオブジェクトがない領域をダブルクリックします。

詳細は、プロパティ エディターを参照してください。

元に戻す/やり直し - 誤りの除去

Figure の [編集] メニューには、最後の操作を元に戻すことのできる次の 2 つの項目が含まれています。

[元に戻す] - 最後に実行した操作による効果を取り消します。

[やり直し] - [元に戻す] を使用して取り消した最後の操作を再度実行します。

たとえば、プロットを作成し、ズームし、表示を移動し、移動操作を元に戻すと、メニューは以下のようになります。

これで前のズーム操作を元に戻すか、元に戻したばかりの移動操作をやり直すことができます。

この情報は役に立ちましたか?