ドキュメンテーション センター

  • 評価版
  • 製品アップデート

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

印刷およびエクスポートの方法

印刷プレビューの利用

Figure を印刷またはエクスポートする前に、Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択してイメージをプレビューします。印刷する Figure またはエクスポートする Figure の外観を調整するには、必要に応じて関数 set を利用します。[印刷プレビュー] ダイアログ ボックスで行った調整は、Figure プロパティも設定します。これらの変更は、print コマンドで後に Figure を印刷する場合にも、出力に影響を与えます。詳細は、Figure の設定の変更を参照してください。

印刷ページにヘッダーを追加

[印刷プレビュー] ダイアログ ボックスの最上部にある[ライン/テキスト] タブをクリックすると、印刷するページにヘッダーを追加することができます。以下に示すように、パネルの下部には [ヘッダー] コントロールがあります。

印刷ヘッダーは印刷ページの上に表示したい任意のテキストを含むことができます。現在の日付も含むことができます。[ヘッダー テキスト] エディット ボックスに、ヘッダーのテキストを入力します。[日付スタイル] で、現在の日付/時間の表示に使用する形式を選択します。既定値は、「なし」に設定されています。[フォント]ボタンをクリックして、ヘッダー テキストと日付形式のフォント、フォント スタイル、フォント サイズ、スクリプト タイプを変更します。指定したとおりにヘッダーが表示されない場合は、プレビュー ペイン上の [更新] ボタンをクリックします。以下のように、太字のイタリック体のヘッダーと日付を含むページがプレビューに表示されます。

[印刷] をクリックして、ページを印刷するために、標準の [印刷] ダイアログ ボックスを開きます。[閉じる] をクリックして、ダイアログ ボックスを閉じ、これらの設定を Figure に適用します。

Figure の印刷

この節では、Figure をプリンターに出力する方法を説明します。

Microsoft Windows の印刷 GUI で印刷する

Windows® プラットフォームでの MATLAB® の印刷には、Windows 標準の [印刷] ダイアログ ボックスが使用されます。これは、ほとんどの Windows ソフトウェア製品で使用されるものです。Windows の [印刷] ダイアログ ボックスを開くには、Figure ウィンドウの [File] メニューから [印刷] を選択するか、[印刷プレビュー] ダイアログ ボックスの [印刷] ボタンをクリックします。

  • Figureを印刷するには、まずリスト ボックスからプリンターを選択してから [OK] をクリックします。

  • Figure をファイルに保存するには、[ファイルへ出力] チェック ボックスをクリックしてから [OK] をクリックし、[ファイルへ出力] ウィンドウが表示されたら Figure を保存するファイル名を入力します。ファイルは現在の作業フォルダーに書き込まれます。

Windows の[印刷] ダイアログ ボックスで行う設定変更は、以下のとおりです。

プロパティ-  プリンター固有の設定を変更するには、[プロパティ] ボタンをクリックします。これにより、Windows のドキュメンテーションの [プロパティ] ウィンドウが開きます。

印刷範囲-  このパネルでは、[すべて] のみが選択可能です。選択肢は、印刷される出力に影響を与えません。

部数-  印刷する部数を入力します。

関数 printdlg を使用すると、プログラムで [印刷] ダイアログ ボックスを開くことができます。

UNIX プラットフォーム上の印刷 GUI で印刷する

UNIX® プラットフォーム上での印刷は、3 つのタブをもつ Print ダイアログ ボックスを使用します。[Print] ダイアログ ボックスを開くには、Figure ウィンドウの [File] メニューから [Print] を選択します。ダイアログ ボックスが表示され、[General] タブの内容が示されています。

Figureを印刷するには、[Print Service] の下の [Name] ボタンをクリックし、リスト ボックスからプリンターを選択します。

    メモ:   印刷ダイアログからアクセスされるプリンターは、PostScript® 出力が可能であると仮定されます。非 PostScript デバイスに印刷する場合は、[File][Save As] を使用し、[Save as type] を指定する必要があります。または、-d フラグで適切なドライバーを指定した print コマンドを実行する必要があります。

[印刷] ダイアログ ボックスの [ページ設定] タブは、以下のようになっています。

用紙の特性と余白を、このタブ上のコントロールを使用して設定できます。代わりに [Print Preview] ダイアログを使用することもできます。同じように設定できるだけでなく、視覚的なフィードバックも同時に得られます。詳細については、印刷プレビューの利用を参照してください。

[Print] ダイアログの [Appearance] タブでは、印刷ジョブのいくつかの側面をコントロールできます。

[Appearance] オプションには、両面印刷やとじる方向、見出しページを印刷ページの前に置くかどうか、カラー印刷にするか、印刷の質などの設定が含まれます。[Print Preview] を使用して、色をコントロールすることもできます。

[Print Preview] ダイアログ ボックスに関連する設定は、以下を含みます。

色の印刷-  使用しているプリンターの機能に応じて、印刷プレビュー の [Color] タブの[Color Scale] パネルから適切なボタンをクリックし、白黒印刷、グレースケール印刷、またはカラー印刷ができます。Figure の色と同じ、または別の背景色が選択できます。

印刷するページの Figure サイズと位置-  印刷されるプロットをスクリーン上の表示と同じサイズにしたい場合は、[Layout] タブの [Auto (Actual Size, Centered)] を選択します。印刷される出力を特定のサイズにする場合は、[Use manual size and position] を選択します。

詳細は、Figure のサイズと位置の設定を参照してください。

Axes の目盛りと範囲-  スクリーン上と同じ目盛り数と軸範囲値で印刷するには、[Print Preview] ダイアログ ボックスの [Advanced] タブで [Keep screen limits and ticks] を選択します。印刷する Figure のサイズに基づいて軸の範囲と目盛りを自動的にスケーリングするには、[Recompute limits and ticks] を選択します。

詳細は、Axes の目盛りと範囲の設定を参照してください。

PostScript コマンドを使用した印刷

関数 print を利用して PostScript コマンド ラインまたはプログラムから印刷します。詳細は、print による印刷とエクスポートを参照してください。

現在の Figure または最後にアクティブであった Figure を送信するには、単に次のように入力します。

print

print リファレンス ページの 「Printing Options table」 は、関数 print で用いるオプションの一覧を示しています。たとえば、次のコマンドでは、Figure No. 2 を 600 dpi の解像度で、Canon® BubbleJet BJ200 プリンター ドライバーを使用して印刷します。

print -f2 -r600 -dbj200

ファイルに出力

Figure を即座にプリンターに送信するのではなく、いったんファイルに出力しておき、後でそのファイルをプリンターに送信するという方法もあります。また、print コマンドを利用して同じファイルに Figure を追加することもできます。

    メモ:   ファイルに出力する場合、ファイル名はパス名を含めて 128 文字未満でなければなりません。現在のフォルダー内のファイルに出力する場合、ファイル名は 126 文字未満でなければなりません。これは、MATLAB は、ファイルを参照するときに、ファイル名の先頭に './' または '.\'' を配置するためです。

ここでは、Figure のファイルへの保存方法を説明します。

Windows プラットフォーム上の印刷 GUI でファイルに出力する

  1. [印刷] ダイアログ ボックスを開くには、Figure ウィンドウの [ファイル] メニューから [印刷] を選択します。

  2. [ファイルへ出力] とラベルの付いたチェック ボックスを選択し、[OK] ボタンをクリックします。

  3. [ファイルへ出力] ダイアログ ボックスが表示され、出力フォルダーとファイル名を指定することができます。

UNIX プラットフォーム上の印刷 GUI でファイルに出力する

  1. [Print] ダイアログ ボックスを開くには、Figure ウィンドウの [File] メニューから [Print] を選択します。

  2. [File] とラベル付けられたラジオ ボタンを選択し、フォルダーとファイル名を記入するか、あるいは参照します。

MATLAB コマンドを使用したファイルへの出力

Figure を PostScript ファイルに出力するには、以下を入力します。

print filename

ファイル名の拡張子を指定しない場合、MATLAB は用いられるプリンター ドライバーに対して、適切な拡張子を利用します。

また、ファイルへの出力時に -options 引数を含めることができます。たとえば、現在の Figure を既存ファイルに挿入するには、以下のように入力します。

print -append filename

ファイルに追加する唯一の方法は、関数 print を使用することです。この処理を行うためのダイアログ ボックスはありません。

    メモ:   Figure をファイルに出力した場合、そのファイルを印刷することはできますが、他のアプリケーションにインポートすることはできません。アプリケーションにインポート可能な Figure ファイルを作成する場合は、次の節「ファイルへのエクスポート」を参照してください。

Figure をファイルに挿入する-  ある Figure を PostScript ファイルに出力すると、関数 print-append オプションを使用して、同じファイルに他の Figure を追加することができます。関数 print を利用すると、挿入のみが可能です。

次の例では、Figure No. 2 を PostScript ファイル myfile.ps に出力し、このファイルの末尾に Figure No. 3 を追加しています。

print -f2 myfile
print -f3 -append myfile

ファイルへのエクスポート

ワードプロセッサのような他のアプリケーションにインポートしたい場合は、Figure をグラフィックス形式でファイルにエクスポートします。Windows または UNIX のエクスポート設定ダイアログ ボックス、あるいはコマンド ラインからファイルにエクスポートすることができます。

ここでは、Figure のファイルへのエクスポート方法を説明します。

以下についても説明します。

詳細については、グラフィックス形式の選択を参照してください。

    メモ:   ファイルにエクスポートする場合、ファイル名はパス名を含めて 128 文字未満でなければなりません。現在のフォルダー内のファイルに出力する場合、ファイル名は 126 文字未満でなければなりません。これは、MATLAB は、ファイルを参照するときに、ファイル名の先頭に './' または '.\'' を配置するためです。

エクスポートの設定 GUI の使用

Figure ウィンドウの [ファイル] メニューから [エクスポート設定] を選択すると、[エクスポート設定] の GUI が表示されます。この GUI には 4 つのダイアログ ボックスがあり、Figure をエクスポートする前に、その Figure のサイズ、レンダリング、フォント、およびラインの外観を調整することができます。[プロパティ] のリストから、[サイズ][レンダリング][フォント][ライン] をクリックすることにより、これらの各ダイアログ ボックスを選択します。各ダイアログ ボックスの説明は、以下を参照してください。

Figure サイズの調整

以下のダイアログ ボックスを表示するには、[エクスポート設定] ダイアログで [サイズ]をクリックします。

サイズ ダイアログ ボックスは、エクスポート ファイルからユーザー アプリケーションにインポートされるときに表示される Figure のサイズを変更します。[幅] および [高さ] の設定を [自動] にしておくと、Figure はスクリーン上の表示と同じサイズになります。[幅] および [高さ] のテキスト ボックスに新しい値を入力し、[Figure に適用]をクリックすることにより、Figure のサイズを変更できます。元の設定に戻すには、[Figure を元に戻す] をクリックします。

変更した設定を保存する、または以前に使用した設定を読み込むには、設定の保存と読み込み を参照してください。

レンダリングの変更

[エクスポート設定] ダイアログ ボックスで、[レンダリング] をクリックすると、次のダイアログ ボックスが表示されます。

このダイアログ ボックスで次のようにして、設定を変更することができます。

カラースペース-  カラースペースを選択するには、ドロップダウン リストを使用してください。以下から選択できます。

  • [白黒]

  • [グレースケール]

  • [RGB カラー]

  • [CMYK カラー]

カスタム カラー-  チェック ボックスをクリックして、Figure の背景として使用される色を入力します。以下のものが使用できます。

  • whiteyellowmagentaredcyangreenblueblack

  • 上記と同じ色に対する省略名 - wymrcgbk

  • 3 要素 RGB 値 - 使用可能な値については、colorspec のヘルプを参照してください。例:[1 0 1] はマゼンタです。[0 .5 .4] は濃い緑です。

カスタム レンダラー-  このチェック ボックスをオンにし、ドロップダウン リストからレンダラーを選択します。

  • painters (ベクトル形式)

  • [OpenGL (ビットマップ形式)]

  • [Z-buffer (ビットマップ形式)]

分解能-  ドロップダウン リストから次のいずれかを選択することができます。

  • [スクリーン] — スクリーン表示で使用されるものと同じ解像度

  • [指定数値] — 150, 300 あるいは 600 dpi

  • [自動] — UNIX が適切な設定を選択します

座標軸の範囲を保持-  軸の目盛りと範囲を、表示したように保つには、チェック ボックスをクリックします。このチェック ボックスがオフになっている場合は、Figure のサイズに応じて自動的に調整されます。

Uicontrol を表示-  チェック ボックスをクリックすると、Figure 内のすべてのユーザー インターフェイス コントロールが表示されます。チェックがない場合は、ユーザー インターフェイス コントロールを非表示にします。

フォント特性の変更

[エクスポート設定] ダイアログ ボックスで [フォント] をクリックすると、以下のダイアログ ボックスが表示されます。

このダイアログ ボックスで次のようにして、設定を変更することができます。

フォント サイズ-  チェック ボックスをクリックし、ラジオ ボタンを使用して Figure 内のテキストの相対的または絶対的なフォント サイズを選択します。

  • フォントのスケーリング N % - すべてのフォントのサイズを相対的な量である N パーセントだけ増加または減少させます。自動的に適切なフォント サイズを選択するようにするためには、auto と入力してください。

  • 最小値 N ポイント - パーセンテージによりフォントをスケーリングする場合、最小のフォント サイズを指定することができます。

  • 固定フォント サイズを使用 N ポイント - すべてのフォントのサイズを絶対的な値である N ポイントに設定します。

フォント名-  チェック ボックスをクリックして、 ドロップダウン リストに表示されたフォント名から選択します。

フォントの太さ-  チェック ボックスをクリックして、ドロップダウン リストから Figure 内のテキストに適用される太さを選択します。[ノーマル][細][中太][太] から選択します。

フォントの角度-  チェック ボックスをクリックして、ドロップダウン リストから Figure 内のテキストに適用される角度を選択します。[ノーマル][イタリック][斜体] から選択します。

ライン特性の変更

[エクスポート設定] ダイアログ ボックスで ライン をクリックすると、次のダイアログ ボックスが表示されます。

このダイアログ ボックスで次のようにして、設定を変更することができます。

ライン幅-  チェック ボックスをクリックして、ラジオ ボタンを使用して Figureの 相対的なまたは絶対的なライン サイズを選択します。

  • ライン幅のスケーリング N % - すべてのラインの幅を相対的な量である N パーセント増加または減少させます。自動的に適切なライン幅を選択するようにするためには、auto と入力してください。

  • 最小値 N ポイント - パーセンテージによりフォントをスケーリングする場合、最小のライン幅を指定することができます。

  • 固定ライン幅の使用 N ポイント - すべてのラインの幅を絶対的な値、N ポイントに設定します。

実線からライン スタイルを周期的に繰り返すように変換する-  カラー グラフィックスが色をサポートしていないアプリケーションにインポートされる場合、固有の色により区別されていたラインは同じように見えます。たとえば、入力レベルを示す赤い線と出力を示す青い線は、いずれもカラー グラフィックスをサポートしていないアプリケーションにインポートされると、黒に見えます。

このチェック ボックスをクリックすると、 色によりラインを区別するのではなく、実線、点線、 または破線など、異なるライン スタイルを使用してラインをエクスポートします。

設定の保存と読み込み

これらのエクスポートの設定を別の機会に再利用する場合、それらを保存して後で再び読み込むことができます。各 [エクスポート設定] ダイアログ ボックスの下部に、[スタイルのエクスポート] とラベルされたパネルがあります。現在のエクスポート スタイルを保存するには、[スタイル名として保存] テキスト ボックスに名前を入力し、[保存]をクリックします。

[設定の読み込み] ドロップダウン リストをクリックすると、読み込み可能なエクスポート スタイルの選択肢の中に、保存したばかりのスタイル名が表示されているはずです。スタイルを読み込むには、このリストから選択肢のいずれか 1 つを選択して、[読み込み]をクリックします。

使用しなくなったスタイルを削除するためには、[スタイルの削除] ドロップダウン リストからそのスタイル名を選択して [削除]をクリックします。

Figure のエクスポート

Figure についてエクスポートのスタイルの設定が終了したら、 4 つの [エクスポート設定] ダイアログ ボックスのいずれかの右側の[エクスポート] ボタンをクリックすると、 Figure をファイルにエクスポートできます。[名前を付けて保存] とラベルされた新しいウィンドウが開きます。

最上部の [保存する場所] リストからファイルを保存するフォルダーを選択します。下部の[ファイルの種類] ドロップダウン リストからユーザーのファイルのファイル タイプを選択し、[ファイル名] テキスト ボックスにファイル名を入力します。[保存] ボタンをクリックして、ファイルをエクスポートします。

MATLAB でサポートされるグラフィックス ファイル形式の詳細は、グラフィックス形式の選択 を参照してください。

MATLAB コマンドを利用するエクスポート

関数 print を利用して MATLAB コマンド ラインまたはプログラムから印刷します。コマンド ラインからの印刷に関する基本情報は、print による印刷とエクスポート を参照してください。

現在の Figure またはアクティブな Figure をエクスポートするには、次のように入力します。

print -dfileformat filename

ここで、fileformat は MATLAB でサポートされるグラフィックス形式で、filename はエクスポート ファイルに与える名前です。拡張子を指定しない場合は、MATLAB が選択します。

関数 print を用いて多くのオプションを指定することもできます。これらは、print のリファレンス ページの印刷オプションの表に記述されています。

たとえば、Figure No. 2 をファイル spline2d.eps に EPS カラー グラフィックス形式を使用して解像度 600 dpi でエクスポートしたい場合は、次のように入力します。

print -f2 -r600 -depsc spline2d

グラフィックス ファイル形式の詳細は、グラフィックス形式の選択選択されるグラフィックス形式の説明の節を参照してください。

getframe を利用したエクスポート

関数 getframe と関数 imwrite を利用して、グラフィックスをエクスポートすることができます。getframe は、ムービーを作成する目的で、一連のフレーム (figure) を取得するためにループ内で用いられることがあります。グラフィックスの固有の解像度にかかわらず、getframe はスクリーンの解像度でキャプチャを行います。

print の利用よりもこのエクスポート方法を利用する利点は、以下のとおりです。

  • getframe を利用すると Figure 全体ではなく Figure の一部をキャプチャできます。

  • imwrite は、ビット深度や圧縮のような形式に固有なオプションの設定については、より柔軟性があります。

この方法の利用の欠点は、以下のとおりです。

  • imwrite が組み込みの MATLAB 形式のみを用います。

  • getframeimwrite は、スクリーンの解像度に制限されます。

そのため、関数 print あるいは[エクスポート] メニューによるエクスポート時に利用可能な GhostScript 形式にアクセスできません。

getframe と imwrite の利用方法-  getframe を利用して、Figure をキャプチャし imwrite を利用してファイルに保存します。getframe は、フィールド cdatacolormap を含む構造体を出力します。colormap フィールドは、トゥルー カラー ディスプレイでは空です。次の例は、現在の Figure をキャプチャし、PNG ファイルにエクスポートします。

I = getframe(gcf);
imwrite(I.cdata, 'myplot.png');

キャプチャされたイメージのタイプに対して適切な imwrite の構文を利用します。上記の例で、イメージはトゥルー カラー ディスプレイからキャプチャされます。colormap フィールドは空なので、imwrite には渡されません。

例 - getframe と imwrite を利用した Figure のエクスポート-  次の例は、デバイス独立 - RGB モードあるいはインデックス付きモードのモニターのいずれかで機能します。

X=getframe(gcf);
if isempty(X.colormap)
   imwrite(X.cdata, 'myplot.bmp')
else
   imwrite(X.cdata, X.colormap, 'myplot.tif')
end

利用可能なファイル形式と各形式固有のオプションの詳細は、imwrite 関数のリファレンス ページを参照してください。一連のフレームからムービーを作成する方法の詳細は、「アニメーション」 を参照してください。

複数の Figure の AVI ファイルへの保存

MATLAB VideoWriter を使用して、複数の Figure を単一の AVI ファイルに保存することもできます。AVI ファイルは、アニメーション化されたシーケンスに対して使用できます。MATLAB を実行する必要はありませんが、AVI ビューアーが必要です。詳細は、「オーディオとビデオへのエクスポート」を参照してください。

MATLAB グラフィックスの他のアプリケーションへのインポート

ワード プロセッシング、スライドの作成、グラフィックス プログラムによる修正、インターネット上のプレゼンテーション等のため、さまざまなアプリケーションに MATLAB グラフィックスを含めることができます。一般に、処理はすべてのアプリケーションに対して同じです。

  1. MATLAB グラフィックスを利用して他のアプリケーションにインポートする Figure を作成します。

  2. MATLAB の Figure をサポートされているグラフィックス ファイル形式のいずれかにエクスポートし、Figure のタイプとして適切であり、ターゲット アプリケーションでサポートされている形式を選択します。ヘルプは、グラフィックス形式の選択 を参照してください。

  3. ターゲット アプリケーションのインポート機能を利用して、グラフィックス ファイルをインポートします。

エクスポートの前の編集-  Vector graphics は、いくつかのハイエンド アプリケーションでは修正可能ですが、ほとんどのアプリケーションは単純なサイズ変更以外の修正をサポートしていません。ビットマップは、画像処理専用のソフトウェア パッケージを利用しない限り、高品質を保ったまま修正することはできません。一般に、Figure が MATLAB 内にある間に必要なすべての設定を行っておくべきです。

Microsoft アプリケーションへのインポート-  エクスポートされた Figure を Microsoft® アプリケーションにインポートするには、[挿入] メニューから[図]を選択します。次に、[ファイルから] を選択し、エクスポートされたファイルに移動します。クリップボードを使用してエクスポートを行う場合は、Microsoft Word および PowerPoint® に対して推奨される MATLAB の設定を使用できます。

例 EPS グラフィックスを LaTeX にインポート-  次の例は、peaks.eps という EPS ファイルを LaTeX にインポートする方法を示します。

\documentclass{article}

\usepackage{graphicx}

\begin{document}

\begin{figure}[h]
\centerline{\includegraphics[height=10cm]{peaks.eps}}
\caption{Surface Plot of Peaks}
\end{figure}

\end{document}

EPS グラフィックスは、LaTeX にインポート後に編集することができます。たとえば、任意の LaTeX 互換の dimension の高さを指定することができます。高さを 3.5 インチに設定するには、次のコマンドを利用します。

height=3.5in

関数 angle を利用してグラフを回転することができます。たとえば、グラフを 90 度回転するには、

angle=90

を、高さを設定するコードと同じ行に [height=10cm,angle=90] のように追加します。

Windows または Macintosh クリップボードへのエクスポート

Figure を Windows または Macintosh のクリップボードにエクスポートすることができます。使用する形式は、以下で説明します。

Windows クリップボード形式

以下の 2 つのグラフィックス形式のいずれかで、グラフィックス データを Windows のシステム クリップボード データにコピーすることができます。EMF カラー ベクトル または BMP 8 ビット カラー ビットマップ形式があります。

既定値では、Figure の表示に用いられるレンダリング法に基づき、グラフィックス形式が自動的に選択されます。OpenGL® または Z-buffer を使ってレンダリングされた Figure について、MATLAB は BMP 形式を利用します。Painter’s を使ってレンダリングされた Figure については、EMF 形式が利用されます。レンダリング法の選択に関しては、MATLAB の既定レンダラー を参照してください。

自動選択をオーバーライドするには、Windows の [コピー オプション設定] ダイアログ ボックスあるいは print コマンドの -d スイッチを利用して形式の選択を指定します。

Macintosh のクリップボード形式

Macintosh プラットフォーム上での (既定の Java® Figure を使用した) クリップボード データは、常に RGB トゥルーカラー ビットマップです。クリップボードにコピーするには、print コマンドでなく [編集][Figure のコピー] を使用します。Figure ウィンドウ全体がキャプチャされます。

GUI を使用したクリップボードへのエクスポート

Figure をクリップボードにエクスポートする前に、[コピー オプション設定] ダイアログ ボックスを利用して、既定ではないグラフィックス形式を選択したり、特定の Figure の設定を調整することができます。これらの設定は、クリップボードにエクスポートされるすべての Figure に対して新規の既定値になります。

    メモ:   Windows metafile 形式 (たとえば print -dmeta) でクリップボードにエクスポートする場合、Figure の [コピー オプション設定] テンプレートからの設定は無視されます。

[コピー オプション設定] ダイアログ ボックスを開くには、Figure ウィンドウの[編集] メニューから[コピーオプション]を選択します。このダイアログ ボックスを利用して行ったすべての変更は、Figure のクリップボード コピーにのみ影響を与えます。Figure の外観には影響を与えません。

[コピー オプション設定] ダイアログ ボックスで変更できる設定は、以下になります。

クリップボード形式-  

  • Figure を EMF カラー ベクトル形式でコピーするには、[メタファイル] を選択します。このオプションは、メタファイルをシステムのクリップボードに置きます。Figureが、ライティング、透明化など、painters レンダラーでサポートされていない機能を使用する場合、クリップボードにコピーされたメタファイルには、Figure のビットマップ表現が含まれます。それ以外の場合、クリップボードにコピーされたメタファイルには、Figure のベクトル表現が含まれます。

  • 形式を自動的に選択するには、[情報を保持] を選択します。“可能な場合メタファイル” パスは、Figureが、ライティング、透明化など、painters でサポートされていないレンダラー機能を使用しているかどうかを確認します。Figure がそのような機能を使用している場合、MATLAB はビットマップを生成します。painters 機能しか使用していない場合、MATLAB はメタファイルを生成します。MATLAB のクリップボード データは、可能な場合はメタファイル形式を使用します。

  • BMP 8 ビット カラー ビットマップ形式を使用するには、[ビットマップ] を選択します。

    メモ:   Macintosh プラットフォームでは、[コピー オプション] ダイアログ ボックスは、[クリップボード形式] オプションをもちません。

Figure の背景色-  背景色をスクリーン上の表示と同様にするには、[Figure の色を利用] を選択します。背景を白色にするには、[背景を強制的に白にする] を選択します。たとえば、Figure の Axes 部分をフレーム化するためのスライドの背景のような透明な背景については、[透明な背景] を選択します。

サイズ-  [Figure のスクリーン サイズと一致] を選択すると、スクリーン上に表示されているとおりに Figure がコピーされます。または、このオプションを選択せずに、[エクスポート設定] ダイアログの [幅] オプションと [高さ] オプションを使用してサイズを決定することもできます。

  1. クリップボードへのコピーで用いられるこれらの設定を変更する必要がある場合は、[コピー オプション設定] ダイアログ ボックスを開きます。

  2. [OK] をクリックして新規設定を参照します。これらは、クリップボードに将来エクスポートされるすべての Figure に対して用いられます。

  3. Figure ウィンドウの [編集] メニューから [Figure のコピー] を選択して、Figure をクリップボードにコピーします。

MATLAB コマンドを使用したクリップボードへのエクスポート

ファイル名を指定せずにグラフィックス形式付きで関数 print を利用して Windows のクリップボードにエクスポートします。-dbitmap あるいは -dmeta のいずれかのクリップボード形式を利用する必要があります。これらのスイッチは、それぞれ Windows Bitmap(BMP) または Enhanced Metafile(EMF) を作成します。

たとえば、現在の Figure を Enhanced Metafile 形式でクリップボードにエクスポートするには、次のように入力します。

print -dmeta

    メモ:   印刷時には、print -d オプションによってプリンター ドライバーを指定します。エクスポート時には、print -d オプションによってグラフィックス形式を指定します。

    print -d を使用して Macintosh システムのクリップボードにグラフィックスをエクスポートすることはできません。

この情報は役に立ちましたか?