ドキュメンテーション センター

  • 評価版
  • 製品アップデート

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

印刷とエクスポートの使用例

スクリーン サイズでの Figure の印刷

既定では、Figure を 8x6 インチに印刷します。このサイズは、背景によって区切られる領域を含みます。次の例は、スクリーン上に表示される Figure と同じサイズで Figureを 印刷またはエクスポートする方法を示します。

グラフィカル ユーザー インターフェイスの利用

  1. Figure ウィンドウをサイズ変更して、印刷時に希望するサイズにします。

  2. Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択し、[レイアウト] タブを選択します。

  3. [配置] パネル上で、[自動 (実際のサイズ、中央)] を選択します。

  4. Figure を印刷するには、右上隅の [印刷] をクリックします。

  5. Figure を印刷するための [印刷] ダイアログ ボックスが開きます。

MATLAB コマンドの利用

Figure を印刷する前に、PaperPositionMode プロパティを auto に設定します。

set(gcf, 'PaperPositionMode', 'auto');
print

後でオリジナル サイズで Figure を印刷する場合は、PaperPositionMode'manual' に設定し直します。

特定の用紙サイズで印刷する

既定では、MATLAB® は 8.5 x 11 インチの用紙を利用します。この例は、用紙タイプ (Legal) を選択することによって、用紙サイズを 8.5 x 14 インチに変更する方法を示します。

グラフィカル ユーザー インターフェイスの使用

  1. Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択し、[レイアウト] タブを選択します。

  2. [用紙] パネルのリストから Legal 用紙タイプを選択します。[幅][高さ] フィールドはそれぞれ 8.514 に更新されます。

  3. [単位] がインチに設定されていることを確認します。

  4. Figure を印刷するには、右上隅の [印刷] をクリックします。

  5. Figure を印刷するための [印刷] ダイアログ ボックスが開きます。

MATLAB コマンドの利用

PaperUnits プロパティを inches に、PaperType プロパティを Legal に設定します。

set(gcf, 'PaperUnits', 'inches');
set(gcf, 'PaperType', 'Legal');

あるいは、PaperSize プロパティを用紙サイズ (単位を指定) に設定することができます。

set(gcf, 'PaperUnits', 'inches');
set(gcf, 'PaperSize', [8.5 14]);

Figure を中心揃えで印刷

次の例は、Figure のサイズを 5.5 x 3 インチに設定し、用紙上で中央揃えにします。

グラフィカル ユーザー インターフェイスの使用

  1. Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択し、[レイアウト] タブを選択します。

  2. [手動設定のサイズと位置を使用] が選択されていることを確認します。

  3. [幅] フィールドに 5.5 を、[高さ] フィールドに 3 を入力します。

  4. [単位] がインチに設定されていることを確認します。

  5. [中央] をクリックします。

  6. [OK] をクリックします。

  7. [印刷] をクリックして、[印刷] ダイアログ ボックスを開き、Figure を印刷します。

MATLAB コマンドの利用

  1. PaperUnitsinches に設定して開始します。

    set(gcf, 'PaperUnits', 'inches')
  2. PaperSize を用いて現在の用紙サイズを出力します。

    papersize = get(gcf, 'PaperSize')
    
    papersize =
                  8.5000   11.0000
  3. Figure の幅と高さに対して変数を初期化します。

    width = 5.5;         % Initialize a variable for width.
    height = 3;          % Initialize a variable for height.
  4. 用紙上で Figure を水平方向に中央揃えする左余白を計算します。計算用に papersize の最初の要素 (用紙の幅) を使います。

    left = (papersize(1)- width)/2
    
    left =
              1.5000
  5. 用紙上で Figure を垂直方向に中央揃えする下余白を計算します。計算用に papersize の 2 番目の要素 (用紙の高さ) を使います。

    bottom = (papersize(2)- height)/2
    
    bottom =
              4
  6. Figure サイズを設定し、印刷します。

    myfiguresize = [left, bottom, width, height];
    set(gcf, 'PaperPosition', myfiguresize);
    print

特定のグラフィックス形式でエクスポート

後でワード プロセッサのような他のアプリケーションにインポートする場合は、Figure をグラフィックス形式でファイルにエクスポートします。

グラフィカル ユーザー インターフェイスの使用

  1. Figure ウィンドウの [ファイル] メニューから[名前を付けて保存] を選択します。

  2. [保存する場所] フィールドを利用して、ファイルを保存したいフォルダーに移動します。

  3. [ファイルの種類] リストからグラフィックス形式を選択します。

  4. [ファイル名] フィールドにファイル名を入力します。選択した形式に基づき、適切なファイル拡張子が表示されます。

  5. [保存] をクリックして Figure をエクスポートします。

MATLAB コマンドの利用

コマンド ラインから、グラフィックス形式をオプションとして指定する必要があります。グラフィックス形式の一覧およびそれらの対応するオプション文字列については、print のリファンレンス ページを参照してください。

次の例は、Figure を現在のフォルダーの EPS カラー ファイル myfigure.eps にエクスポートします。

print -depsc myfigure

次の例は、Figure No. 2 を解像度 300 dpi で myfigure.jpg という 24 ビット JPEG ファイルにエクスポートします。

print -djpeg -f2 -r300 myfigure

次の例は、Figure をスクリーン サイズで myfigure.tif という 24 ビット TIFF ファイルにエクスポートします。

set(gcf, 'PaperPositionMode', 'auto')   % Use screen size
print -dtiff myfigure

TIFF プレビュー付きの EPS 形式でエクスポート

関数 print を使って TIFF プレビュー付きの EPS 形式で Figure をエクスポートします。Figure のインポート時にアプリケーションは、ソース ドキュメンテーションの TIFF プレビューを表示することができます。プレビューは、エクスポートされた Figure がカラーの場合はカラーで、モノクロの場合はモノクロです。

次の例は、Figure を EPS カラー形式ファイル myfigure.eps にエクスポートし、カラーの TIFF プレビューを含みます。

print -depsc -tiff myfigure

次の例は、Figure を EPS black-and-white 形式ファイル myfigure.eps にエクスポートし、black-and-white TIFF プレビューを含みます。

print -deps -tiff myfigure

Figure をクリップボードにエクスポート

Figure を Windows® または Macintosh のワード プロセッサなど別のアプリケーションに貼り付ける場合は、グラフィックス形式でクリップボードにエクスポートします。

グラフィカル ユーザー インターフェイスの利用

次の例は、Figure をクリップボードに Enhanced Metafile(EMF) 形式でエクスポートします。Figure の設定は、エクスポートされる Figure が Microsoft® Word や PowerPoint® のスライドでの使用に適切となるように選択されています。設定を変更すると、スクリーン上に表示される Figure が修正されます。

  1. テキストを含む Figure を作成します。次のコードを利用することができます。

    x = -pi:0.01:pi; 
    h = plot(x, sin(x));
    title('Sine Plot');
    
  2. Figure の [ファイル] メニューから [設定] を選択します。その後、[設定] ダイアログ ボックスから [Figure のコピー テンプレート] を選択します。

  3. [Figure のコピー テンプレート設定] パネルで、[PowerPoint] ボタンをクリックします。MATLAB が推奨する PowerPoint 用の設定がテンプレートに追加されます。

  4. [ライン] パネルで、[ライン幅] を 4 ポイントに変更します。

  5. [Uicontrol と Axes] パネルで [Axes の範囲と目盛の間隔を保持] を選択して MATLAB がエクスポート時に目盛りと範囲を再スケーリングするのを回避します。

  6. [Figure に適用] をクリックします。変更が Figure ウィンドウに表示されます。

    新規設定を使った Figure の外観が気に入らない場合は、[Figure を元に戻す] ボタンをクリックしてオリジナルの設定に戻ることができます。

  7. [設定] ダイアログ ボックスの左パネルで、[Figure のコピー テンプレート]トピックを展開します。コピー オプションを選択します。

  8. [コピー オプション] パネルで [メタファイル] を選択することにより、Figure が EMF 形式でエクスポートされるようにします。

  9. [透明な背景] が選択されていることを確認します。この選択肢は、Figure の背景を透明にし、スライドの背景を Figure の Axes 部分のフレームにします。

  10. [Figure のスクリーン サイズと一致] チェック ボックスをオフにすることにより、Figure のサイズを独自に設定できるようにします。

  11. [OK] をクリックします。

  12. Figure ウィンドウの [ファイル] メニューから [エクスポート設定] を選択します。

  13. サイズ プロパティを選択し、6高さ4.5 に設定します。単位がインチに設定されていることを確認します。

  14. [閉じる] をクリックします。

  15. [編集] メニューから [Figure のコピー] を選択します。Figure はクリップボードにエクスポートされ、PowerPoint のような別の Windows アプリケーションに貼り付けることができます。

MATLAB コマンドの利用

関数 print と 2 つのクリップボード形式 (-dmeta-dbitmap) のうちの 1 つを利用して、Figure をクリップボードにエクスポートします。ファイル名は指定しないでください。

次の例は、Figure をクリップボードに Enhanced Metafile(EMF) 形式でエクスポートします。

print -dmeta

次の例は、Figure をビットマップ (BMP) 8 ビット カラー形式でクリップボードにエクスポートします。

print -dbitmap
この情報は役に立ちましたか?