ドキュメンテーション センター

  • 評価版
  • 製品アップデート

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

Figure の設定の変更

印刷に影響を与えるパラメーター

下記の表は、Figure をプリンターに送信する前に設定可能なパラメーターを示します。

「パラメーター」列は、変更可能なすべてのパラメーターを示しています。

「既定値」列は、MATLAB® の既定の設定を示しています。

「ダイアログ ボックス」列は、そのパラメーターを設定するために使用するダイアログ ボックスを示しています。1 つのプラットフォームに対してのみこの設定を行う場合は、Windows® については(W)、UNIX® については (U) と表記されます。

一部のダイアログ ボックスの上部にはタブがあり、特定のカテゴリを選択することができます。これらのカテゴリは、下の表では <dialogbox>/<tabname> の形式を使用して表記されています。たとえば、この列の 印刷プレビュー/レイアウト... は、[印刷プレビュー] ダイアログ ボックスを使い、[レイアウト]タブを選択することを意味します。

print コマンドまたは set プロパティ」列は、MATLAB 関数 print または set を利用してパラメーターを設定する方法を示しています。print の利用では、表は適切なコマンド オプション (たとえば print -loose) を示します。set の利用では、プロパティ名とオブジェクトのタイプを示します (たとえば、(Line) はライン オブジェクトの意)。

パラメーター

既定値

ダイアログ ボックス

print コマンドまたはset プロパティ

Figure の選択

最新のアクティブウィンドウ

なし

print -fhandle

プリンターの選択

システムの既定値

印刷

print -pprinter

Figure のサイズ

8 x 6 インチ

印刷プレビュー/レイアウト

PaperSize (Figure) PaperUnits (Figure)

ページの位置

左から 0.25 インチ、下から 2.5 インチ

印刷プレビュー/レイアウト

PaperPosition (Figure) PaperUnits (Figure)

位置モード

手動

印刷プレビュー/レイアウト

PaperPositionMode (Figure)

用紙の種類

Letter

印刷プレビュー/レイアウト

PaperType (Figure)

用紙方向

印刷プレビュー/レイアウト

PaperOrientation (Figure)

レンダラー

自動選択

印刷プレビュー/詳細設定

print -zbuffer | -painters | -opengl

レンダラー モード

自動

印刷プレビュー/詳細設定

RendererMode (Figure)

解像度

ドライバーまたはグラフィックス形式により異なる

印刷プレビュー/詳細設定

print -rresolution

軸範囲とメモリ

再計算

印刷プレビュー/詳細設定

XTickMode, etc. (Axes)

背景色

白にする

印刷プレビュー/色

Color (Figure) InvertHardCopy (Figure)

フォント サイズ

Figure と同じ

印刷プレビュー/ライン/テキスト

FontSize (Text)

太字フォント

標準フォント

印刷プレビュー/ライン/テキスト

FontWeight (Text)

ライン幅

Figure と同じ

印刷プレビュー/ライン/テキスト

LineWidth (Line)

ライン スタイル

黒または白

Figure のコピー テンプレート

LineStyle (Line)

ラインとテキストの色

モノクロ

印刷プレビュー/ライン/テキスト

Color (Line, Text)

CMYK 色

RGB カラー

印刷プレビュー/色 (U)

print -cmyk

UI control

印刷

印刷プレビュー/詳細設定

print -noui

境界ボックス

タイト

N/A

print -loose

「コピーの背景」

透明

コピー オプション (W)

「背景色」を参照

「コピー サイズ」

スクリーン サイズと同じ

コピー オプション (W)

「Figure のサイズ」を参照

Figure の選択

既定では、現在の Figure を印刷します。複数の Figure が開かれている場合は、現在の Figure は最後にアクティブであった Figure です。別の Figure をアクティブにするには、クリックして前面に移動させます。

MATLAB コマンドの使用

以下のコマンドを使って、Figure のハンドルを指定します。

print -fhandle

次の例は、Figure No. 2 をプリンターに送信します。Figure の番号は通常、そのハンドルです。

print -f2

プリンターの選択

[印刷] ダイアログ ボックスまたは関数 print を使って利用するプリンターを選択することができます。

グラフィカル ユーザー インターフェイスの使用

  1. Figure ウィンドウの [ファイル] メニューから [印刷] を選択します。

  2. [印刷] ダイアログ ボックスの一番上付近のリスト ボックスからプリンターを選択します。

  3. [OK] をクリックします。

MATLAB コマンドの使用

関数 print-P スイッチを利用してプリンターを選択することができます。

次の例は、Figure No. 3 を Calliope というプリンターに印刷します。

print -f3 -PCalliope

プリンター名にスペースが含まれる場合は、以下のように -P オプションを単一引用符で囲みます。

print '-Pmy local printer'

ネットワーク プリンター サーバーの利用-  Windows システムでは、PRINTERS という名前のコンピューター上の trinity という名前のプリンターに対して、下記の形式を利用してネットワーク プリンター サーバーに印刷することができます。

print -P\\PRINTERS\trinity

    メモ:   Windows プラットフォームでは、使用するプリンターを -P オプションで指定すると、-dwin または -dwinc 以外のドライバーを指定している場合、MATLAB の出力は適切な拡張子をもつファイルに送信されますが、プリンターには送信されません。このファイルを後でプリンターにコピーすることができます。

Figure のサイズと位置の設定

既定の Figure の出力サイズは、幅が 8 インチ、高さが 6 インチで、MATLAB の Figure ウィンドウの縦横比 (幅と高さ) を保持します。Figure の既定の位置は、用紙サイズが 8.5 x 11 インチで印刷すると、水平方向および垂直方向に中央揃えされます。

Figure のサイズと位置は変更可能です。

グラフィカル ユーザー インターフェイスの使用

[印刷プレビュー] ダイアログ ボックスを開くには、Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択します。[レイアウト] タブをクリックして、印刷ページでの Figure のサイズと位置を変更します。

左側のテキスト エディット ボックスを利用して、新規 Figure の大きさを入力します。あるいは、右側のペインにあるルーラー上のハンドルバーを利用し、マウスを使って Figure の余白と位置をドラッグします。外側のハンドルバーでは、Figure に最も近い余白を調整します。中央のハンドルバーでは、縦横比を変えずに Figure のページ上の位置を変更します。ハンドルバーを使用中は、ガイドラインが現れます。

[レイアウト] タブで変更可能な設定は、以下のとおりです。

配置-  Figure をスクリーン上の表示と同じサイズにするか、[レイアウト] ペインのオプションを利用して手動でサイズを変更するかのいずれかを選択します。

[手動設定のサイズと位置を使用] モードを選択した場合は、4 つの余白のうち任意のものの幅を入力します。プレビュー イメージは、幅を入力するたびに更新されます。ペインの下側にある [単位] セクションから、単位 (インチ、センチメートル、またはポイント) を選択します。

[配置] セクションの下にある 4 つのボタンを使用して、Figure を用紙サイズに合わせて拡張したり、印刷の縦横比 (x と y の範囲の比) を Figure の縦横比に合わせたり、Figure をページの中央に配置したり、[印刷プレビュー] ダイアログを開いたときの設定を復元したりすることができます。[用紙に合わせる] を選択すると、イメージの縦横比が変わる場合があります。縦横比を変えずに、Figure を最大のサイズで印刷するには、[縦横比を固定] を選択します。

自動 (実際のサイズ、中央)-  このオプションを選択すると、Figure は用紙上の中央に置かれます。Figure ウィンドウ内と同じサイズになります。コントロールの下の 4 つのボタンは、このオプションを選択すると薄くなります。

    メモ:   印刷プレビューを利用して行う変更は、印刷される出力のみに影響を与えます。これらの設定によって、スクリーン上の Figure の表示が変更されることはありません。

MATLAB コマンドの使用

特定のサイズまたは位置で Figure を印刷するには、PaperPositionMode プロパティが manual (既定値) に設定されていることを確認します。その後で、PaperPosition プロパティを必要なサイズおよび位置に設定します。

PaperPosition プロパティは、印刷される出力の位置と大きさを指定する 4 要素行ベクトルを参照します。ベクトル形式は、以下のとおりです。

[left bottom width height]

ここで、

  • left は、用紙の左端から Figure の左端までの距離を指定します。

  • bottom は、用紙の底辺から Figure の底辺までの距離を指定します。

  • widthheight は、Figure の幅と高さを指定します。

PaperPosition の既定値は、以下のとおりです。

[0.25 2.5 8.0 6.0]

次の例は、Figure サイズを幅 4 インチ、高さ 2 インチ、Figure の始点が用紙の左端から 2 インチ、下端から 1 インチになるように設定します。

set(gcf, 'PaperPositionMode', 'manual');
set(gcf, 'PaperUnits', 'inches');
set(gcf, 'PaperPosition', [2 1 4 2]);

    メモ:   PaperPosition は、印刷プレビューが行うように上余白ではなく下余白を指定します。印刷プレビューを利用して上余白を設定する際、MATLABは、下余白を計算するためにこの設定を利用し、適切に PaperPosition プロパティを更新します。

用紙サイズまたはタイプの設定

用紙サイズは、大きさを指定するか、あるいは既定の用紙形式の一覧から選択して設定します。用紙サイズまたは形式を設定しない場合、MATLAB は既定の用紙サイズ 8.5 x 11 インチを用います。

用紙サイズの設定と用紙形式の設定は、相互に関係します。用紙形式を設定すると、MATLAB は用紙サイズを更新します。たとえば、用紙形式を US Legal に設定する場合は、MATLAB は、用紙の幅を 8.5インチ、高さを 14 インチに更新します。

用紙サイズと方向は変更可能です。

グラフィカル ユーザー インターフェイスの使用

[印刷プレビュー] ダイアログ ボックスを開くには、Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択します。[レイアウト] タブをクリックして用紙形式を変更し、印刷されるページでの Figure の方向を変更します。

[レイアウト] タブで変更可能な設定は、以下のとおりです。

用紙の形式、単位、向き-  [形式] の一覧から用紙タイプを選択します。適切な大きさの用紙タイプがない場合は、ユーザーが大きさを [幅][高さ] フィールドに入力します。[単位] が適切に、インチ、センチメートル、ポイントに設定されていることを確認してください。用紙の幅と高さを設定した後に単位を変更する場合は、[幅][高さ] フィールドは選択された単位を使用するように更新されます。プレビューペインの用紙の範囲は、単位を変更すると新規の用紙の形式またはサイズを示すように更新されます。

[印刷の向き] のボタンを使用し、印刷ページ上での Figure の向きを選択します。用紙の方向の設定 の下の図は、選択可能な 3 つのタイプの方向を示しています。

    メモ:   印刷プレビューを利用して行う変更は、印刷される出力のみに影響を与えます。これらの設定によって、スクリーン上の Figure の表示が変更されることはありません。

MATLAB コマンドの使用

PaperType プロパティを組み込みの MATLAB 用紙タイプのいずれかに設定するか、あるいは PaperSize プロパティを用紙の大きさに合わせて設定します。

用紙形式の選択の際に、測定単位は自動的に更新されません。PaperUnits プロパティをまず設定することを推奨します。

たとえば、以下のコマンドは単位を centimeters に、用紙形式を A4 に設定します。

set(gcf, 'PaperUnits', 'centimeters');
set(gcf, 'PaperType', 'A4');

次の例は、単位を inches に、用紙サイズを 5 x 7 インチに設定します。

set(gcf, 'PaperUnits', 'inches');
set(gcf, 'PaperSize', [5 7]);

一致する用紙形式がない用紙サイズを設定した場合は、PaperType プロパティは自動的に 'custom' に設定されます。

用紙の方向の設定

用紙の方向は、用紙が Figure に対してどの方向をとるのかを示します。[縦] (既定値)、[横][回転] から選択できます。

Figure の方向は変更可能です。

下図は、異なる方向を用いて印刷された同じ Figure を示します。

    メモ:   方向の [回転] は、すべてのプリンターでサポートされるわけではありません。プリンターがサポートしない場合は、横が用いられます。

グラフィカル ユーザー インターフェイスの使用

  1. Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択し、[レイアウト] タブを選択します(グラフィカル ユーザー インターフェイスの使用を参照してください)。

  2. [方向] の下の適切なオプション ボタンを選択します。

  3. [閉じる] をクリックします。

MATLAB コマンドの利用

PaperOrientation Figure プロパティまたは関数 orient を利用します。Figure を常に用紙上で中央揃えにする場合は、関数 orient を利用します。

以下の例は、方向を landscape に設定します。

set(gcf, 'PaperOrientation', 'landscape');

Figure の中央揃え-  PaperOrientation プロパティを portrait から他の 2 つの方向のいずれかに変更すると、中央揃えされていたイメージが用紙の端の方に寄ってしまうことがあります。位置を調整する (PaperPosition を利用する) か、あるいは Figure を常に用紙の中央に設定する関数 orient を利用することができます。

関数 orient は、PaperOrientation と同じ引数名を用います。たとえば、次のようになります。

orient rotated; 

レンダラーの選択

レンダラーは、Figure を表示、印刷、エクスポートするために、(頂点座標のような) グラフィックス データを処理するソフトウェアまたはハードウェアです。Figure を印刷するときは、レンダラーを、その Figure の描画時に使用したものから別のものに変更することができます。

サポートされるレンダラー

MATLAB は、以下の特性をもつ 3 つのレンダリング法をサポートします。

Painter's

  • ベクター グラフィックスを使って Figure を描画する

  • 通常、高解像度の結果を生成する

  • Figure が単純な、あるいは小さいグラフィックス オブジェクトのみを含む場合は最速のレンダラー

  • HP-GL® プリンター ドライバーによる印刷時または Adobe® Illustrator ファイルへのエクスポート時にのみ使用可能なレンダラー

  • PostScript® または EPS ファイルの作成に最適のレンダラー

  • Patch または Surface オブジェクトに対して RGB カラーを利用する Figure はレンダリングできません

  • ライティングも透明度も表示しません

Z-buffer

  • ビットマップ (ラスター) グラフィックスを使って Figure を描画

  • Painter's よりも高速で正確

  • MATLAB が複雑な表示を行っている場合は、多くのシステムメモリを消費する場合があります

  • ライティングは表示しますが透明度は表示しません

OpenGL®

  • ビットマップ (ラスター) グラフィックスを使って Figure を描画

  • 通常、Painter's および Z-buffer より高速

  • 一部のシステムで利用可能なグラフィックス レンダリング ハードウェアにアクセス可能

  • ライティングと透明度の両方を表示

レンダリング法の変更についての詳細は、Figure Renderer プロパティを参照してください。

OpenGL のハードウェアによる実装とソフトウェアによる実装の比較

OpenGL の実装には、ハードウェアとソフトウェアの 2 種類があります。

  • ハードウェアによる実装は、パフォーマンス向上のために特殊なグラフィックス ハードウェアを使用するため、ソフトウェア版よりもかなり高速です。多くのコンピューターではこの特殊なハードウェアがオプションとして用意されています。また、工場出荷時に既にこのハードウェアが搭載されている場合もあります。

  • ソフトウェアによる OpenGL の実装は、MATLAB Version 5.0 以降で提供されている Zbuffer レンダラーとよく似ています。ただし、一般的には OpenGL の方が、Zbuffer よりも優れたパフォーマンスを提供します。

OpenGL の可用性

OpenGL は、MATLAB を実行するすべてのコンピューターで使用できます。MATLAB では、OpenGL のハードウェア アクセラレータ版を使用できる場合、このバージョンが自動的に検出されます。ハードウェア アクセラレータ版を使用できない場合、MATLAB ではソフトウェア版が使用されます。ただし、ソフトウェア版の OpenGL がサポートされていない Macintosh システムは除きます。

以下のソフトウェア版が提供されています。

  • UNIX システムでは、MATLAB は配布されている MATLAB に付属の OpenGL のソフトウェア版を使用します。

  • Windows では、OpenGL はオペレーティング システムの一部として提供されています。OpenGL で問題が発生した場合には、使用しているグラフィックス ドライバーのベンダーに連絡し、最新の認定バージョンの OpenGL を入手してください。

  • Macintosh システムでは、ソフトウェア版の OpenGL は使用できません。

MATLAB では、使用可能な OpenGL ライブラリを検出できない場合、警告が発生されます。

OpenGL のハードウェア アクセラレータ版またはソフトウェア版の選択

MATLAB では、OpenGL のハードウェア アクセラレータ版とソフトウェア版を切り替えることができます。ただし、Windows システムと UNIX システムでは、動作が次のように異なります。

  • Windows システムでは、MATLAB セッション中、いつでもソフトウェア版とハードウェア版を切り替えられます。

  • UNIX システムでは、MATLAB が OpenGL を初期化する前に、OpenGL の版を設定する必要があります。したがって、opengl ソフトウェアを呼び出す前に、opengl info コマンドの発行やグラフの作成を行うことはできません。ハードウェア アクセラレータ版の OpenGL を再度有効にするには、MATLAB を再起動しなければなりません。

  • Macintosh システムでは、ソフトウェア版の OpenGL は使用できません。

ハードウェア版の OpenGL を使わずにオブジェクトの透明性を使用する場合は、次のコマンドを実行します。

opengl software 

このコマンドを実行すると、MATLAB にソフトウェア版 OpenGL の使用を強制できます。ソフトウェア版の OpenGL は、ハードウェア アクセラレータ版の OpenGL が正しく機能しない際に OpenGL レンダラーを必要とするイメージ、パッチ、または表面の透明度を使用する場合に役立ちます。ハードウェア版の OpenGL を再度有効にするには、次のコマンドを使用します。

opengl hardware 

このコマンドを、Windows システムで実行するか、UNIX システムで MATLAB を再起動します。

既定では、MATLAB はハードウェア アクセラレータ版の OpenGL を使用します。

詳細は、関数 opengl のリファレンス ページを参照してください。

使用しているバージョンの確認

システムで MATLAB が使用している OpenGL ライブラリのバージョンおよびベンダーを確認するには、MATLAB プロンプトに次のコマンドを入力します。

opengl info

返される情報には、MATLAB が OpenGL のソフトウェア版を使用している (Software = true) かハードウェア アクセラレータ版を使用している (Software = false) かを示す行が含まれています。

また、このコマンドは、MATLAB が使用している特定のライブラリで使用可能な OpenGL 仕様の拡張子の文字列も返します。これは MathWorks® においては有用な参考情報ですので、バグをレポートする際にはこの情報を含めるようにしてください。

opengl info コマンドを発行すると、MATLAB によって OpenGL が初期化される点に注意してください。

OpenGL とその他の MATLAB レンダラー

OpenGL で作成された描画と他のレンダラーで作成された描画には、いくつかの相違点があります。OpenGL に固有の相違点は以下のとおりです。

  • OpenGL は、カラーマップの内挿を行いません。インデックス付きカラー、内挿された面、またはエッジの色付けを使用して、表面またはパッチを作成した場合、OpenGL はカラーマップではなく、RGB カラー キューブを使用して色を内挿します。

  • OpenGL では、surfaces および patchesFaceLighting プロパティと EdgeLighting プロパティに対して phong 値はサポートされていません。

  • OpenGL では、対数スケールの軸はサポートされていません。

  • OpenGL と Zbuffer のレンダラーは、モニター上と同様に、オブジェクトを前から後ろの順に並べ替えて表示します。また、線と面がモニター上の同一場所にある場合、常に線が面の前面に描画されます。Painters は、子オブジェクトの順に (指定された順序で) 並べ替えます。

MATLAB の既定レンダラー

既定値では、OpenGL により、Figure の属性 (複雑度とさまざまな Handle Graphics® プロパティの設定) および場合によってはプリンター ドライバーまたは使用されるファイル形式に基づいて、レンダリング法の最適化が自動的に試みられます。

一般にレンダラーは以下のように選択されます。

  • ライン プロット、エリア プロット (棒グラフ、ヒストグラム等) および単純な表面プロットについて Painter’s を利用します。

  • コンピューター スクリーンがトゥルー カラーでないか、あるいは selection_modeneverselect を設定して関数 opengl が呼び出されたときは、Z-buffer を利用します。

  • 内挿されたシェーディングを利用している複雑な表面プロットおよびライティングを利用している Figure に対しては、OpenGL を利用します。

RendererMode プロパティは、レンダラーが Figure の内容に基づいて自動的に選択される (auto に設定) か、あるいはユーザーが指定した Renderer プロパティが使用される (manual に設定) かを示します。

レンダラーを手動設定する理由

ユーザーが独自にレンダラーを設定する 2 つの理由は以下のとおりです。

  • 印刷あるいはエクスポートされる Figure をスクリーン上の外観と同様にするためです。Figure の印刷およびエクスポートに利用されるレンダリング法は、Figure の表示に用いられるレンダリング法と必ずしも一致しているわけではありません。

  • 意図せずにベクトル形式内にビットマップとして Figure をエクスポートするのを防ぐためです。たとえば、複雑度の高い MATLAB プロットでは典型的に OpenGL または Z-buffer が使用されます。複雑度の高い Figure をレンダリング法を指定せずに EPS または EMF ベクトル形式にエクスポートすると、MATLAB はビットマップ グラフィックスを作成する OpenGL または Z-buffer を利用する可能性があります。

    ビットマップをベクトルファイルに格納することは、印刷に時間がかかる非常に大きいファイルを生成する場合があります。これらの形式のいずれかを使い、Figure がベクトル ファイルとして保存されるようにする場合は、レンダリング法を確実に Painter's に設定してください。

グラフィカル ユーザー インターフェイスの使用

  1. Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択して、[印刷プレビュー] ダイアログ ボックスを開きます。[詳細設定] タブを選択します。

  2. [レンダラー] ドロップダウン メニューで、リスト ボックスからレンダリング方法を選択します。

  3. [閉じる] をクリックします。

MATLAB コマンドの使用

Renderer プロパティまたは関数 print のスイッチを利用して、印刷やエクスポート用のレンダラーを設定することができます。以下の 2 行は、それぞれ現在の Figure に対するレンダラーを Z-buffer に設定します。

set(gcf, 'Renderer', 'zbuffer');

または

print -zbuffer

最初の例は、Figure と共に Renderer の新規の値を保存します。2 つ目の例は現在の印刷またはエクスポートの操作にのみ効力をもちます。

Renderer プロパティを設定すると、RendererMode プロパティが auto (出荷時の既定値) から manual に自動的にリセットされます。

解像度の設定

解像度は、印刷またはエクスポートの際に Figure がどの程度正確にレンダリングされるかを意味します。高解像度は高品質の出力を生成します。解像度の具体的な定義は、Figure がビットマップ グラフィックスまたはベクトル グラフィックスのどちらとしての出力であるかによって異なります。

Figure の印刷に用いる解像度は変更可能です。

既定の解像度とその変更が可能な場合

既定の解像度は、用いられるレンダラーと指定したグラフィックス形式またはプリンター ドライバーにより異なります。次の 2 つの表は、既定の解像度とそれらが変更可能かどうかをまとめたものです。

グラフィックス形式で使用される解像度

グラフィックス形式

既定の解像度

変更

組み込み MATLAB エクスポート形式 (EMF, EPS, ILL を除く)

150 dpi (常に OpenGL または Z-buffer を利用)

はい

EMF エクスポート形式 (Enhanced Metafile)

150 dpi

はい

EPS (Encapsulated PostScript)

OpenGL または Z-buffer の場合は 150 dpi、Painter’s の場合は 864 dpi

はい

ILL エクスポート形式 (Adobe Illustrator)

72 dpi (常に Painter's を利用)

いいえ

Ghostscript エクスポート形式

72 dpi (常に OpenGL または Z-buffer を利用)

いいえ

プリンター ドライバーで使用される解像度

プリンター ドライバー

既定の解像度

変更

Windows と PostScript ドライバー

OpenGL または Z-buffer の場合は 150 dpi、Painter’s の場合は 864 dpi

はい

Ghostscript ドライバー

OpenGL または Z-buffer の場合は 150 dpi、Painter’s の場合は 864 dpi

はい

HP-GL ドライバー

1116 dpi (常に Painter's を利用)

はい

設定の選択

解像度の条件は、テストした上で決定する必要がある場合もありますが、以下のガイドラインを利用することもできます。

印刷-  既定の解像度 150 dpi は一般的なレーザプリンター出力に対して通常適切です。しかしながら、テキストブックやカラー ブローシャのような高品質印刷のための Figure では、200 あるいは 300 dpi が必要です。利用可能な解像度は、プリンターの機能により制限される場合があります。

エクスポート-  Figure をエクスポートする場合は、最終出力デバイスでサポートされている解像度に基づいて判断してください。たとえば、Figure をワード プロセッシング ドキュメントにインポートし、最大解像度設定が 300 dpi であるプリンターで印刷する場合は、解像度を 300 dpi にして Figure をエクスポートすると、ファイル内のピクセルと用紙上のドットが正確に 1 対 1 で対応します。

    メモ:   エクスポート時に解像度を設定する唯一の方法は、関数 print を利用することです。

必要なサイズとメモリへの解像度の影響

解像度はファイル サイズとメモリの必要条件に影響を与えます。印刷とエクスポートの両方について高い解像度を設定すると、Figure をレンダリングする時間が長くなります。

グラフィカル ユーザー インターフェイスの利用

組み込みの MATLAB プリンター ドライバーの解像度を設定するには、次のようにします。

  1. [印刷] ダイアログ ボックスから [プロパティ] をクリックします。これにより、新規のダイアログ ボックスが開きます(このボックスはプリンターごとに異なります)。

  2. このダイアログから解像度を設定するか、[詳細設定] をクリックして、表示されるダイアログ ボックスで解像度を設定できます。

  3. 解像度を設定して [OK] をクリックします(解像度の設定は、“印刷の品質” のように別の名前でラベル付けられている場合があります)。

MATLAB コマンドの利用

Windows のプリンター ドライバーを利用する場合は、Windows のドキュメンテーションのプロパティ ダイアログ ボックスを利用した場合にのみ解像度を設定することができます。

それ以外は、印刷またはエクスポート用の解像度を設定するためには、次の構文を使います。

print -rnumber

ここで、number はインチあたりのドット数です。スクリーン解像度を利用して印刷またはエクスポートするには、number0 (ゼロ) に設定します。

次の例では、現在の Figure を解像度 100 dpi で印刷しています。

print -r100

次の例は、現在の Figure をスクリーン解像度を利用して TIFF ファイルにエクスポートします。

print -r0 -dtiff myfile.tif

Axes の目盛りと範囲の設定

既定の出力サイズ、8 x 6 インチは、通常スクリーン サイズよりも大きいものです。印刷またはエクスポートされる Figure のサイズがスクリーン上のサイズと異なる場合、軸の目盛りの数と位置は出力サイズに合わせてスケーリングされます。ここでは、それらをロックして、表示されたときと同じ状態にする方法を説明します。

MATLAB Figure の印刷に用いる解像度は変更可能です。

グラフィカル ユーザー インターフェイスの利用

[印刷プレビュー] ダイアログ ボックスを開くには、Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択します。[詳細設定] タブを選択し、Axes、UI コントロール、またはレンダラーの設定を変更します。

[詳細設定] タブで変更可能な設定は、以下のとおりです。

軸範囲と目盛り-  印刷またはエクスポートされる Figure のサイズがスクリーン上のサイズと異なる場合、軸の目盛りの数と位置は出力サイズに合わせてスケーリングされます。表示と同じ状態になるようにロックするには、[スクリーン範囲と目盛りを維持する] を選択します。印刷用のスケーリング時に目盛りと範囲が自動的に調整されるようにするには、[範囲と目盛りを再計算する] を選択します。

その他-  [レンダラー] のドロップダウン メニューを使用して、どのレンダラーを Figure の印刷に使用するかを指定します。レンダラーを [Painters][Z-buffer][OpenGL] に設定します。あるいは [自動] を選択すると、Figure の特性に応じて、どれを使用するかを自動的に決められます(レンダラーの選択を参照してください)。

[解像度] のドロップダウン メニューを使用して、Figure の表示と印刷に対する解像度をインチ当たりのドット数 (DPI) で指定します。[150][300][600] DPI が選択でき、異なる値 (正の整数) が入力できます。

Figure UI コントロール-  既定では、ユーザー インターフェイス コントロールは、印刷あるいはエクスポートされる Figure に含まれます。[UIControl を印刷] チェック ボックスをオフにすると、ユーザー インターフェイス コントロールは除外されます(ユーザー インターフェイス コントロールを印刷出力から除外するを参照してください)。

    メモ:   印刷プレビューを利用して行う変更は、印刷される出力のみに影響を与えます。これらの設定によって、スクリーン上の Figure の表示が変更されることはありません。

MATLAB コマンドの使用

XTickModeYTickModeZTickMode プロパティを、manual に設定するには、以下のように入力します。

set(gca, 'XTickMode', 'manual');
set(gca, 'YTickMode', 'manual');
set(gca, 'ZTickMode', 'manual');

背景色の設定

印刷するときは、背景色をスクリーンに表示されているとおりにするか、白に変更することができます。Figureでは、Axes の背景と Figure の背景の 2 種類の背景色が設定できます。どちらの背景も既定の表示色は灰色ですが、いくつかの色の中から任意に選択して設定できます。

表示されている Figure の背景色が何であれ、印刷またはエクスポートするとき、既定では背景色は常に白に変更されます。ここでは、出力内で表示される背景の色を保持する方法を示します。

グラフィカル ユーザー インターフェイスの利用

Figure とごに背景を保持するには、次のようにします。

  1. Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択して、[印刷プレビュー] ダイアログ ボックスを開きます。[色] タブを選択します。

  2. [Figure と同じ] を選択します。

  3. [閉じる] をクリックします。

クリップボードを用いて Figure をエクスポートしている場合は、[設定] ダイアログ ボックスの[コピー オプション]パネルを使います。

MATLAB コマンドの利用

背景色を保持するには、以下を使用します。

set(gcf, 'InvertHardCopy', 'off');

次の例は、Figure の背景色を blue、Axes の背景色を yellow に設定し、InvertHardCopyoff に設定して、これらの色が印刷またはエクスポートされる Figure に示されるようにします。

set(gcf, 'color', 'blue');
set(gca, 'color', 'yellow');
set(gcf, 'InvertHardCopy', 'off');

ラインとテキストの特性の設定

Figure を Microsoft® Word や PowerPoint® のアプリケーションで使用する場合は、ラインとテキストの特性をこれらのアプリケーション用の推奨値に設定することができます。Figure の [コピー テンプレート設定] ダイアログ ボックスは、Word と PowerPoint オプションにより、それらの設定を行ったり、あるいはラインとテキストの特性を個々に設定することができます。

ラインとテキストの特性は変更可能です。

グラフィカル ユーザー インターフェイスの利用

Figureのコピー テンプレート設定を開くには、[ファイル] メニューから [設定] を選択し、左側のペインの [Figure のコピー テンプレート] をクリックします。

Figure の [コピー テンプレート設定] ダイアログ ボックスで変更可能な設定は、以下になります。

Microsoft Word または PowerPoint-  [ドキュメント] または [プレゼンテーション] をクリックして、MATLAB の推奨設定を適用します。

テキスト-  [テキスト] の下のオプションを使用して、Figure 内のすべてのテキストの外観を修正します。フォント サイズの変更、テキスト カラーのモノクロへの変更、フォント スタイルの太字への変更が可能です。

ライン-  [ライン] オプションを使用して、Figure 内のすべてのラインの外観を修正します。

  • ライン幅 — ライン幅を変更します。

  • スタイルを変更 (黒または白) — 色付けされたラインを黒または白に変更します。

  • スタイルを変更 (黒と白) — 実線を他のライン スタイル (例、実線、破線など)、およびモノクロに変更します。

UIControl と Axes-  Figure がユーザー インターフェイス コントロールを含む場合は、[Uicontrol を表示]をクリックすることによって、それらを表示あるいは非表示にするかを選択ができます。また、軸の範囲と目盛をスクリーン上の状態のままにするには、[Axes の範囲と目盛の間隔を保持] をクリックします。印刷する Figure のサイズを基に座標軸の範囲と目盛りを自動スケーリングするには、このボックスをオフにします。

    メモ:   印刷プレビューを利用して行う変更は、印刷される出力のみに影響を与えます。これらの設定によって、スクリーン上の Figure の表示が変更されることはありません。

MATLAB コマンドの利用

Figure 内で選択されたグラフィックス オブジェクトに対して関数 set を利用して、個々のラインとテキストの特性を変更することができます。

たとえば、ライン幅を 1.8 に、ライン スタイルを破線に変更するには、次のようにします。

lineobj = findobj('type', 'line');
set(lineobj, 'linewidth', 1.8);
set(lineobj, 'linestyle', '--');

フォント サイズを 15 ポイント、フォントの重みを太字に変更するには、次のようにします。

textobj = findobj('type', 'text');
set(textobj, 'fontunits', 'points');
set(textobj, 'fontsize', 15);
set(textobj, 'fontweight', 'bold');

ラインとテキスト カラーの設定

色付けされたラインとテキストがモノクロ プリンターによって灰色になる場合は、テキスト文字を構成する細いラインについて良い結果を得られません。しかしながら、Figure 内のすべてのラインとテキスト オブジェクトを、強制的にモノクロで印刷し、印刷されたコピーでの表示を改良することができます。この設定を選択する際、ラインとテキストは背景色に応じて、すべて黒またはすべて白で印刷されます。

既定では、ラインとテキストをスクリーン上に表示される色のままにします。

    メモ:   背景色は、スクリーン上に表示されているものと必ずしも同じではありません。印刷時に背景色を維持するオプションについては、[色] タブを参照してください。

Figure の印刷に用いる解像度は変更可能です。

グラフィカル ユーザー インターフェイスの使用

[印刷プレビュー] ダイアログ ボックスを開くには、Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択します。[ライン/テキスト] タブを選択して、印刷されるページのすべてのラインとテキストの色を変更します。[ライン/テキスト] タブのコントロールは、以下のとおりです。

[ライン/テキスト] で変更可能な設定は、以下のとおりです。

ライン-  このパネルの既定のオプションでは、ラインは Figure ウィンドウに描画される幅と同じように印刷されます。[スケーリング] フィールドを使用すると、ライン幅を 0 パーセントからスケーリングして印刷することができます。特定のポイント サイズでラインを印刷するには、[カスタム] を選択します。[カスタム] オプションを選択した場合、プロット上のすべてのラインは同じ太さになります。[スケーリング] オプションを選択した場合は、各ラインの相対的な太さが尊重されます。

ラインの幅を小さくするとき、[最小幅][カスタム]に設定し、そのフィールドに最小ライン幅をポイント単位で入力すると、線が薄れるのを防ぐことができます。

テキスト-  既定では、印刷されるテキストは、Figure と同じサイズで同じフォントになります。フォントを (すべてのテキストに対して) 変更するには、[カスタム] を選択し、表示されるドロップダウン リストから新規フォントを選択します。フォント サイズのスケールは、[スケーリング] オプションを使用します。特定のポイント サイズでテキストを印刷するには、[カスタム] を選択します。[カスタム] オプションを選択した場合、プロット上のすべてのテキストは、指定したポイント サイズで印刷されます。[スケーリング] オプションを選択した場合は、相対的なフォント サイズが尊重されます。[テキスト] パネルの下のドロップダウン メニューを使用して、すべてのテキストに適用される [フォントの太さ] (ノーマル、細、中太、太) および [フォントの角度] ([ノーマル][イタリック][斜体]) を指定できます。

ヘッダー-  [ヘッダー テキスト] の編集フィールドに、印刷する Figure の上部に表示されるテキストを入力します。今日の日付や時間をヘッダー テキストに追加する場合は、[日付スタイル] のポップアップ メニューから適切な形式を選択してください。ヘッダー フォント (Figure で使用されるフォントには依存しません) を指定してスタイルを設定するには、[フォント] ボタンをクリックし、表示される [フォント] 選択ウィンドウからフォント名、サイズ、スタイルを選択します。

    メモ:   印刷プレビューを利用して行う変更は、印刷される出力のみに影響を与えます。これらの設定によって、スクリーン上の Figure の表示が変更されることはありません。

MATLAB コマンドの利用

背景色に応じて、ラインとテキストの色を設定する、等価な MATLAB コマンドはありません。Figure 内の Line オブジェクトまたはテキスト オブジェクトに関数 set を使用して、ラインやテキストの色を設定します。

次の例は、すべてのラインとテキストを黒に設定します。

set(findobj('type', 'line'), 'color', 'black');
set(findobj('type', 'text'), 'color', 'black');

印刷またはエクスポート用にカラー スペースを指定する

既定では、RGB カラー スペース (赤, 緑, 青) でカラー出力を生成します。印刷業界の標準である 4 色の分類を利用して、MATLAB の Figure を変換および印刷する場合は、CMYK カラー スペース (シアン、マゼンタ、黄色、黒) を利用する場合もあります。

Windows グラフィカル ユーザー インターフェイスの利用

[印刷プレビュー] ダイアログ ボックスを開くには、Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択します。[色] タブを選択して、印刷されるページのすべてのラインとテキストの色を変更します。[色] タブのコントロールは、以下のとおりです。

Figure のコンテンツは、パネルから適切なボタンを選択して、白黒、グレースケール、カラーで印刷できます。[色] を選択すると、[RGB] (赤、緑、青) または [CMYK] (シアン、マゼンタ、黄、黒) の色指定を選択できます (プリンターがその色指定に対応している場合)。

[カラー スケール] コントロールに関係なく、印刷の [背景色] を指定できます。Figure に使用されている色 (既定値はグレー) を使うために [Figure と同じ] を選択するか、コンボ ボックスのポップアップ メニューから [カスタム] の色を指定します。選択肢は、黒、白、RGB 三原色の値です。gmagenta.3 .4 .5 のように、このフィールドには有効な MATLAB のカラースペックを入力できます。

指定した背景色は、[カラー スケール] パネルの [白黒] または [グレー スケール] を選択しても適用されます。

UNIX プラットフォームでのグラフィカル ユーザー インターフェイスの利用

  1. Figure ウィンドウの [File] メニューから [Print] を選択します。

  2. [Appearance] タブをクリックします。

  3. [Color Appearance] パネルで [Color] を選択します。

  4. [Print] をクリックします。

どのプラットフォームでも、カラー印刷、グレースケール印刷、または白黒印刷を [印刷プレビュー] ダイアログ ボックスで指定できます。

MATLAB コマンドの利用

関数 print-cmyk オプションを利用します。次の例は、現在の Figure を CMYK で、PostScript Level II カラー プリンター ドライバーを利用して印刷します。

print -dpsc2 -cmyk

ユーザー インターフェイス コントロールを印刷出力から除外する

ユーザー インターフェイス コントロールは、ユーザーが作成して Figure に追加するオブジェクトです。たとえば、別の MATLAB ファイルを実行するためのボタンを Figure に加えることができます。既定では、ユーザー インターフェイス コントロールは、印刷あるいはエクスポートされる Figure に含まれます。ここでは、それらの除外方法を説明します。

グラフィカル ユーザー インターフェイスの使用

  1. Figure ウィンドウの [ファイル] メニューから [印刷プレビュー] を選択して、[印刷プレビュー] ダイアログ ボックスを開き、[詳細設定] タブを選択します。

  2. [その他] の下の [UIControl を印刷] チェック ボックスをクリアします。

  3. [閉じる] をクリックします。

MATLAB コマンドの利用

-noui スイッチを使用します。次の例は、カラーの PostScript ドライバーを指定し、UI コントロールを除外します。

print -dpsc -noui

次の例は、現在の Figure をカラーの EPS ファイルにエクスポートし、UI control を除外します。

print -depsc -noui myfile.eps

Uncropped Figure の生成

ほとんどの場合、背景は Figure 内のオブジェクトの周囲ぎりぎりにトリミング (cropped) されます。利用するプリンター ドライバーまたはファイル形式に応じて、Uncropped の出力を生成することができます。Uncropped Figure は背景の領域が増え、UI control を含む Figure に適していることがあります。

MATLAB で行う設定により、Figure と共に保存された PostScript BoundingBox プロパティを変更します。

MATLAB コマンドの使用

関数 print-loose オプションを利用します。Windows プラットフォームでは、uncropped オプションはファイルに印刷する場合にのみ利用可能です。

次の例は、現在の Figure を Uncropped で EPS ファイルにエクスポートします。

print -deps -loose myfile.eps
この情報は役に立ちましたか?