Documentation Center

  • 評価版
  • 製品アップデート

surfview

Open Surface Viewer

Syntax

surfview('a') 

Description

The Surface Viewer, invoked using surfview('a'), is a GUI tool that lets you examine the output surface of a FIS stored in a file, a.fis, for any one or two inputs. Because it does not alter the fuzzy system or its associated FIS structure in any way, Surface Viewer is a read-only editor. Using the drop-down menus, you select the two input variables you want assigned to the two input axes (X and Y), as well the output variable you want assigned to the output (or Z) axis.

If you want to create a smoother plot, use the Plot points field to specify the number of points on which the membership functions are evaluated in the input or output range. This field defaults to a value of 101.

Click Evaluate to perform the calculation and plot the output surface.

By clicking on the plot axes and dragging the mouse, you can manipulate the surface so that you can view it from different angles.

If there are more than two inputs to your system, you must supply the constant values associated with any unspecified inputs in the reference input section.

Refer to The Surface Viewer for more information about how to use surfview.

Menu Items

On the Surface Viewer, there is a menu bar that allows you to open related GUI tools, open and save systems, and so on. The Surface Viewer uses the same File menu as the one on the FIS Editor. Refer to fuzzy for more information:

  • Use the Edit menu items:

    Undo to undo the most recent action

    FIS properties to invoke the FIS Editor

    Membership functions to invoke the Membership Function Editor

    Rules... to invoke the Rule Editor

  • Use the View menu item:

    Rules to invoke the Rule Viewer

  • Use the Options menu items:

    Plot to choose among eight different kinds of plot styles.

    Color Map to choose among several different color schemes.

    Always evaluate to automatically evaluate and plot a new surface every time you make a change that affects the plot, such as changing the number of grid points. This option is selected by default. To clear this option, select it once more.

See Also

| | | | |

Was this topic helpful?